summaryrefslogtreecommitdiff
path: root/dev-python/beartype/beartype-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 14:50:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 14:50:54 +0100
commit5772eab78c27d5409ea9e818a12abc9f686e7319 (patch)
tree781df06984c0a557c2fade1ffa96a39378bfbf7c /dev-python/beartype/beartype-0.15.0.ebuild
parent45219c7455b2c8bce47bdf428b44a6a38d6ce521 (diff)
gentoo auto-resync : 22:07:2023 - 14:50:54
Diffstat (limited to 'dev-python/beartype/beartype-0.15.0.ebuild')
-rw-r--r--dev-python/beartype/beartype-0.15.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/beartype/beartype-0.15.0.ebuild b/dev-python/beartype/beartype-0.15.0.ebuild
new file mode 100644
index 000000000000..1600c2778175
--- /dev/null
+++ b/dev-python/beartype/beartype-0.15.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+)