summaryrefslogtreecommitdiff
path: root/dev-python/bashate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/bashate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/Manifest3
-rw-r--r--dev-python/bashate/bashate-0.3.1.ebuild33
-rw-r--r--dev-python/bashate/metadata.xml18
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/bashate/Manifest b/dev-python/bashate/Manifest
new file mode 100644
index 000000000000..c739bbaa51ab
--- /dev/null
+++ b/dev-python/bashate/Manifest
@@ -0,0 +1,3 @@
+DIST bashate-0.3.1.tar.gz 16016 BLAKE2B 72bcb6ef2c8dda48b40351f37971473b9c2137f3a727a355f1742f20355aee8a3898d4aaf61e0e6538b22adbe3ebd34bb30d67d0fb6b5f3535c9b46c1544ce5d SHA512 dfa3e8f98879169cef445cc9a788b4ed051630330e2270c721e472f080899d6742cd3deb571049ba6b943ada0fc77a70f5a7e4742a54d1ca6d5f075a92a00ffb
+EBUILD bashate-0.3.1.ebuild 696 BLAKE2B 8526f14e3d10b51de9c2951567af7ffcf5c34dce7275597285058f10fef7be965c79178c1e25becd3ce85f91beab3420093c5c5fdf5d22c2e98827092f7c5c00 SHA512 c7273658b675a68e334b2b1de30afc7947d334c1fecf31cf90f1f0be7aeeb5705158d4aa114d2541e89ee03f7359738be5960316f73099cf69e42711064dd29a
+MISC metadata.xml 517 BLAKE2B 74c61fabea9ee345173582be1486426377f97187d976b992380d6670fb024c00ccfa818e6bac19e1e637c371280ca8d5535c8e84bff52ae874eeae939728a400 SHA512 eca862a58ed6a1571e626ddc24e73fb8d295f0a6e5fa36246d261688d9de81ff7780018df8defd159094ed8badf8449982dcf07c2415067080f38ba516da481f
diff --git a/dev-python/bashate/bashate-0.3.1.ebuild b/dev-python/bashate/bashate-0.3.1.ebuild
new file mode 100644
index 000000000000..2f938d16f2d9
--- /dev/null
+++ b/dev-python/bashate/bashate-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+DISTUTILS_IN_SOURCE_BUILD=TRUE
+
+# time
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/bashate/metadata.xml b/dev-python/bashate/metadata.xml
new file mode 100644
index 000000000000..c25cf671b7a9
--- /dev/null
+++ b/dev-python/bashate/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ A pep8 equivalent for bash scripts
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">bashate</remote-id>
+ </upstream>
+</pkgmetadata>