summaryrefslogtreecommitdiff
path: root/dev-python/bashate/bashate-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-python/bashate/bashate-0.6.0.ebuild
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-python/bashate/bashate-0.6.0.ebuild')
-rw-r--r--dev-python/bashate/bashate-0.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/bashate/bashate-0.6.0.ebuild b/dev-python/bashate/bashate-0.6.0.ebuild
new file mode 100644
index 000000000000..3348f8aac55d
--- /dev/null
+++ b/dev-python/bashate/bashate-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+DISTUTILS_IN_SOURCE_BUILD=TRUE
+
+# time
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+"
+RDEPEND="
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-pythn/Babel-2.4.0
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}