summaryrefslogtreecommitdiff
path: root/dev-python/basemap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/basemap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/basemap')
-rw-r--r--dev-python/basemap/Manifest4
-rw-r--r--dev-python/basemap/basemap-1.0.7-r1.ebuild72
-rw-r--r--dev-python/basemap/basemap-1.0.7-r2.ebuild72
-rw-r--r--dev-python/basemap/metadata.xml19
4 files changed, 167 insertions, 0 deletions
diff --git a/dev-python/basemap/Manifest b/dev-python/basemap/Manifest
new file mode 100644
index 000000000000..5b225b8d2278
--- /dev/null
+++ b/dev-python/basemap/Manifest
@@ -0,0 +1,4 @@
+DIST basemap-1.0.7.tar.gz 129694711 BLAKE2B ec2159b01711584384d472205f8d3cadd06cfca07202421be534d7778f94000ccc9ae4b8e07a9fd595b7c06c335ec7af7ac2e9d84f7418bb0db1aeab67125559 SHA512 dc8ef8f02127813c9460c6a9c22c593616bbe8ff39f6507abb786d344c710b296bf4f21759b5c1e6fc8ccf3f478d8fb6f546429528575d13f732c4233aaf9c20
+EBUILD basemap-1.0.7-r1.ebuild 2109 BLAKE2B 426212f7c37a86c8641b320423013f3defc62d3e1713ab772f6d1c903f2e5ed17591400167a3f4e6effd6e61a879bade981c036cbae314e6830eb249e24e574e SHA512 420009da6a233adc632097c977e48061742ab508b2ce064e93be70efac4fd4f04c48549c2134d88b4bf5c66a21c435bf1601d5ce4248d01f67b5e0f9e4388bf9
+EBUILD basemap-1.0.7-r2.ebuild 2148 BLAKE2B fcc69936999cf0fbcccfc00bd37952aead4237afdf9a1e56c2339ca6c227857ea67b37e1f03c88b0ded1d04be60580b0d3c6774a649b87c64d5e336b897bd4a1 SHA512 7742fd0223a61c4d9dc9024f221c6759989d5c4f5e41453079bf68f887503a8259f047068011a34bc3e1781382b60433fc14bba1359b9d59912ceb86f4ce4696
+MISC metadata.xml 613 BLAKE2B 899d7032acf24b4d5a03efe56d537172d6b10105a71636afbaa63762f4669afb7116cceec9e1be1ef7c8ed23f03d9066b2ace57876770bc49450020e57121cae SHA512 f00ec05a0bf306703627b8a4846a20dcc4503646df4c38ae75f360c452e4e824db537cde0f93d037840583f3c245453387a665ca9ebf5356be45be84588893ee
diff --git a/dev-python/basemap/basemap-1.0.7-r1.ebuild b/dev-python/basemap/basemap-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..71e1f0548063
--- /dev/null
+++ b/dev-python/basemap/basemap-1.0.7-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="matplotlib toolkit to plot map projections"
+HOMEPAGE="https://matplotlib.org/basemap/ https://pypi.org/project/basemap/"
+SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
+
+IUSE="examples test"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT GPL-2"
+
+CDEPEND="sci-libs/shapelib
+ >=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.3.1[python,${PYTHON_USEDEP}]"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/dap[${PYTHON_USEDEP}]"
+
+DOCS="FAQ API_CHANGES"
+#REQUIRED_USE="test? ( examples )"
+# The test phase ought never have been onvoked according to the above.
+# The test phase appears to require the package to fist be emerged, which ...
+# Until the distutils_install_for_testing func refrains from failing with
+# mkdir: cannot create directory ‘/test’: Permission denied
+# reluctantly this phase is assigned
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ setup.py || die
+ # use /usr/share/data
+ sed -i \
+ -e "/_datadir.*=.*join/s|\(.*datadir.*=\).*|\1'${EROOT}usr/share/${PN}'|g" \
+ "${S}"/lib/mpl_toolkits/basemap/*.py || die
+ distutils-r1_src_prepare
+ append-flags -fno-strict-aliasing
+}
+
+#src_test() {
+# distutils_install_for_testing
+#}
+
+python_install() {
+ distutils-r1_python_install
+ # --install-data="${EPREFIX}/usr/share/${PN}" on testing is found not to work;
+ # setup.py is a mess. Someone care to patch setup.py please proceed; substitute with
+ insinto usr/share/basemap/
+ doins lib/mpl_toolkits/basemap/data/*
+
+ # clean up collision with matplotlib
+ rm -f "${D}$(python_get_sitedir)/mpl_toolkits/__init__.py"
+ # respect FHS
+ rm -fr "${D}$(python_get_sitedir)/mpl_toolkits/basemap/data"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/basemap/basemap-1.0.7-r2.ebuild b/dev-python/basemap/basemap-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..6c21c113bf73
--- /dev/null
+++ b/dev-python/basemap/basemap-1.0.7-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="matplotlib toolkit to plot map projections"
+HOMEPAGE="https://matplotlib.org/basemap/ https://pypi.org/project/basemap/"
+SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
+
+IUSE="examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT GPL-2"
+
+CDEPEND="sci-libs/shapelib
+ >=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.3.1[python,${PYTHON_USEDEP}]"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/dap[${PYTHON_USEDEP}]"
+
+DOCS="FAQ API_CHANGES"
+#REQUIRED_USE="test? ( examples )"
+# The test phase ought never have been onvoked according to the above.
+# The test phase appears to require the package to fist be emerged, which ...
+# Until the distutils_install_for_testing func refrains from failing with
+# mkdir: cannot create directory ‘/test’: Permission denied
+# reluctantly this phase is assigned
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ setup.py || die
+ # use /usr/share/data
+ sed -i \
+ -e "/_datadir.*=.*join/s|\(.*datadir.*=\).*|\1'${EROOT}usr/share/${PN}'|g" \
+ "${S}"/lib/mpl_toolkits/basemap/*.py || die
+ distutils-r1_src_prepare
+ append-flags -fno-strict-aliasing
+}
+
+#src_test() {
+# distutils_install_for_testing
+#}
+
+python_install() {
+ # mpl_toolkits namespace provided by dev-python/matplotlib
+ rm "${BUILD_DIR}/lib/mpl_toolkits/__init__.py" || die
+ distutils-r1_python_install --skip-build
+ # --install-data="${EPREFIX}/usr/share/${PN}" on testing is found not to work;
+ # setup.py is a mess. Someone care to patch setup.py please proceed; substitute with
+ insinto /usr/share/basemap/
+ doins lib/mpl_toolkits/basemap/data/*
+
+ # respect FHS
+ rm -r "${D}$(python_get_sitedir)/mpl_toolkits/basemap/data" || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/basemap/metadata.xml b/dev-python/basemap/metadata.xml
new file mode 100644
index 000000000000..c19fcc082854
--- /dev/null
+++ b/dev-python/basemap/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <longdescription>
+ basemap is a matplotlib toolkit. It allows to plot data on map
+ projections (with continental and political boundaries).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">matplotlib</remote-id>
+ </upstream>
+</pkgmetadata>