summaryrefslogtreecommitdiff
path: root/dev-python/basemap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-python/basemap
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-python/basemap')
-rw-r--r--dev-python/basemap/Manifest1
-rw-r--r--dev-python/basemap/basemap-1.0.7-r2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/basemap/Manifest b/dev-python/basemap/Manifest
index d4c91f31d082..0a1dcd97eca5 100644
--- a/dev-python/basemap/Manifest
+++ b/dev-python/basemap/Manifest
@@ -1,3 +1,4 @@
DIST basemap-1.0.7.tar.gz 129694711 BLAKE2B ec2159b01711584384d472205f8d3cadd06cfca07202421be534d7778f94000ccc9ae4b8e07a9fd595b7c06c335ec7af7ac2e9d84f7418bb0db1aeab67125559 SHA512 dc8ef8f02127813c9460c6a9c22c593616bbe8ff39f6507abb786d344c710b296bf4f21759b5c1e6fc8ccf3f478d8fb6f546429528575d13f732c4233aaf9c20
EBUILD basemap-1.0.7-r1.ebuild 2111 BLAKE2B 39b7307f5a2193331a5e2ea4846a09675aa2b0a2abbfcdc5f9f4d7aba5ad88cdc425f8ce7a5c484e8d65506859c151983dc0e8b20a9d7b9ba885aa07757b4a62 SHA512 c0e07fea6e6270dfcd92aedf2a7c639788f564dae1a789c3b1860d7d202eb9bbc992d71b50f75f362065a887d0fa363ba4328f4f7936a37b6731a939c52f6f4a
+EBUILD basemap-1.0.7-r2.ebuild 2150 BLAKE2B 0054ffdea249e2ff5f11cd383b9f61b3540f1370193e3375a3cfb298b76b6aa3289c08a8ac7e331753f4647fc72e8bffabfd7a40e6cf6dff5733a10ce4151640 SHA512 8cddb366bc3fe683442ac053f9a1dacd16a6738e730d3cb334ff677d09665d94fa1449fa9c8cb36ee0daeeb26fc4f7c82451b002f6a99fa8470c72c1bc613487
MISC metadata.xml 613 BLAKE2B 899d7032acf24b4d5a03efe56d537172d6b10105a71636afbaa63762f4669afb7116cceec9e1be1ef7c8ed23f03d9066b2ace57876770bc49450020e57121cae SHA512 f00ec05a0bf306703627b8a4846a20dcc4503646df4c38ae75f360c452e4e824db537cde0f93d037840583f3c245453387a665ca9ebf5356be45be84588893ee
diff --git a/dev-python/basemap/basemap-1.0.7-r2.ebuild b/dev-python/basemap/basemap-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..3b90867698e7
--- /dev/null
+++ b/dev-python/basemap/basemap-1.0.7-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="matplotlib toolkit to plot map projections"
+HOMEPAGE="http://matplotlib.org/basemap/ https://pypi.python.org/pypi/basemap"
+SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
+
+IUSE="examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT GPL-2"
+
+CDEPEND="sci-libs/shapelib
+ >=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.3.1[python,${PYTHON_USEDEP}]"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/dap[${PYTHON_USEDEP}]"
+
+DOCS="FAQ API_CHANGES"
+#REQUIRED_USE="test? ( examples )"
+# The test phase ought never have been onvoked according to the above.
+# The test phase appears to require the package to fist be emerged, which ...
+# Until the distutils_install_for_testing func refrains from failing with
+# mkdir: cannot create directory ‘/test’: Permission denied
+# reluctantly this phase is assigned
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ setup.py || die
+ # use /usr/share/data
+ sed -i \
+ -e "/_datadir.*=.*join/s|\(.*datadir.*=\).*|\1'${EROOT}usr/share/${PN}'|g" \
+ "${S}"/lib/mpl_toolkits/basemap/*.py || die
+ distutils-r1_src_prepare
+ append-flags -fno-strict-aliasing
+}
+
+#src_test() {
+# distutils_install_for_testing
+#}
+
+python_install() {
+ # mpl_toolkits namespace provided by dev-python/matplotlib
+ rm "${BUILD_DIR}/lib/mpl_toolkits/__init__.py" || die
+ distutils-r1_python_install --skip-build
+ # --install-data="${EPREFIX}/usr/share/${PN}" on testing is found not to work;
+ # setup.py is a mess. Someone care to patch setup.py please proceed; substitute with
+ insinto /usr/share/basemap/
+ doins lib/mpl_toolkits/basemap/data/*
+
+ # respect FHS
+ rm -r "${D}$(python_get_sitedir)/mpl_toolkits/basemap/data" || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}