summaryrefslogtreecommitdiff
path: root/dev-python/bandit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/bandit
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest3
-rw-r--r--dev-python/bandit/bandit-1.7.2-r1.ebuild35
-rw-r--r--dev-python/bandit/bandit-1.7.2.ebuild34
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 3fc468cf27e9..eaa37fb703d1 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,3 +1,6 @@
DIST bandit-1.7.1.tar.gz 503072 BLAKE2B 1e88b662d8dda0d5c1a1fd7ee2eaa1787b8c4952acefb60c347aa98b3534d9ba212229b050dcf717169fb39132ef77d2d92af834392a0bcaa0b9fbc7d2a4804c SHA512 6543bb0f69339a8d970cf0dd1bcec1392057c5c7fbf229fa4f4e6c9d21a39206f1f3fa17509ca2038cd1671d4b57316f92ee053c1beab102e8d20096d10b685d
+DIST bandit-1.7.2.tar.gz 497104 BLAKE2B 235e8c29658db9b0916b2108a46931581384851650217a7e368f06fe9225aadf181b320a75061387b277d1e3ff3f1d38fe6d07be14f7c7d056fa06e8db84e4e4 SHA512 fde27d409dcb867285f3c7a9ee88a079dae58211e17c2157601bbff9e9144e604def3c0179a7c9016266bdf70ed9da9ca519641f4aca4e76a30859c8e01177b9
EBUILD bandit-1.7.1.ebuild 979 BLAKE2B 7af2866ee9bacb49dcb5a694f9cad843e267dc12619900b71d142bf0519a620149d9d648eda9d59c01d5ae1bbab25429b89c75e13ae01559b414ac0dbcc4c947 SHA512 b9254fe3c2fdcb5e70f95851e1b9a7bc52d69d24299deebb719cf7018b9e47ad920bc16475b17324a312e7158b8a39fce6c78bac894c7d3c7e07d116254e82a4
+EBUILD bandit-1.7.2-r1.ebuild 1004 BLAKE2B 0e6d0b50e3dad94430492404b9cbc17a75265fcffc5531f92e7584f8ea9ab59fd8e1a56fdb130b7585ce03e252dc02f60e8c2270f5d4a83f38bb79ef6af81917 SHA512 1368bddfc4c702c807f4b591ca7fa1372a67fbccd8f134388e6623382e619c8d52dfb927e9917212568b3c6888d8eff1d9f6f691731172b6770ceab014367c84
+EBUILD bandit-1.7.2.ebuild 982 BLAKE2B a6ea2f1a60d8bf8afda54efe5b9419c04e59bce48882309c3bc353605bad55ab9126c2534deaf21b5e751a07c3fd8c1c6f9446dfb371f875d6856ba64b388430 SHA512 9dc2967d0e34e6dd8e1fc84deb566efb6381944d7d65e88302a712a1606bcbbb0264f20a9d0ad2adbcedfeaa0dae3cda6a237c0e2428dcd6681e743c96321a25
MISC metadata.xml 685 BLAKE2B 5312eb62f7c19c1e45c23366d84804e731e07194a4b3e00675b7d9002101b59ca6113f910f6c6164995f97c8bb338e2d59ebeb40a2ef69d4efa905558a050791 SHA512 f516aa698ae72ddf53cc3b448ea5a128c77d79364d606aad87f8df87510db7f7776a9ac2cdca04ca62829e872319fc838402dba54775481622a4e1e9e99381fd
diff --git a/dev-python/bandit/bandit-1.7.2-r1.ebuild b/dev-python/bandit/bandit-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..0857a573ec73
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
diff --git a/dev-python/bandit/bandit-1.7.2.ebuild b/dev-python/bandit/bandit-1.7.2.ebuild
new file mode 100644
index 000000000000..073ca031a6d0
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install unittest