summaryrefslogtreecommitdiff
path: root/dev-python/babelfish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/babelfish
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/babelfish')
-rw-r--r--dev-python/babelfish/Manifest5
-rw-r--r--dev-python/babelfish/babelfish-0.5.5-r1.ebuild8
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild4
-rw-r--r--dev-python/babelfish/files/babelfish-0.5.5-py310.patch51
4 files changed, 62 insertions, 6 deletions
diff --git a/dev-python/babelfish/Manifest b/dev-python/babelfish/Manifest
index 09d3463003dd..0c381fe1b517 100644
--- a/dev-python/babelfish/Manifest
+++ b/dev-python/babelfish/Manifest
@@ -1,4 +1,5 @@
+AUX babelfish-0.5.5-py310.patch 1777 BLAKE2B 0d3871c4037f159a8e20f96e3005f5984fd9ba4cdc7364047dad74b4388b8a42bf264028f64e73de10903886bc9fb082e8eadc09268c5a2b340e11a940e92faf SHA512 194050cdfc90021d0cfdfbb3fa620f46d3fa96dd601ccd58a0eb62b75d7569952ce7560e8787a7ae51b1d86a305883bf2d13818eac62507ca4284b15a24b23a5
DIST babelfish-0.5.5.tar.gz 90398 BLAKE2B 3266a92ba5c68d7b801fa9cd13417d04b4a4526ba9fbee34116e356e42857bc36a68b085626a084047d7f9dc512d71d45cebfd06af65ed35bd2478b6957d00d9 SHA512 71504dd0203ad85a6a69107d67df3bd5ae4193515e74c05b346a8bd0aab425fc1534d54d1c74b14e48580ee5e76f04705e35c2d359fbe46254bee37e41cb4bfa
-EBUILD babelfish-0.5.5-r1.ebuild 461 BLAKE2B 5d5ca29c4b43332d8ce49d6b994949dd592a84a7a00f11b7cef034c77df60b3b632fe0430c7e6e7b29fd1e3a65edc005acf7b8e6528feb75143dafbbf3bdc47f SHA512 52797ef04dd9346ddf50b8b9ca523deda8e64d9ed3518a9a221be928767b80a634180b2248e323a4bbe0e82e6fd356dad3a2761acf5c725fa69131207185bba4
-EBUILD babelfish-9999.ebuild 435 BLAKE2B 92e29c09eca9a5362b6fabc4e2ee7eca4820c9d192b0762465fb2846295d57754f2175d35f0df72d632e1388696aa2f9982a1d6bfef75afd428c621c0119caf6 SHA512 89d6949ef625f4e04589c5bd62bb50cbd28ce3713a7f50090cb022fa05eff427c27f11773310fd2e3f41aea519b880327b1923376e798972caccc472f0120a04
+EBUILD babelfish-0.5.5-r1.ebuild 506 BLAKE2B 34c92e5aec893e8862ee9c9925b7cafeb72566c83ed6ed135a93ff29c002de913c9659d3494b2975c0e786cba84ef208d10eaa844b70e0eeca4fe7a10f190fbf SHA512 c5873af559df194d4eabdc5613c633799e4be5fac487e92eda693e808f252b39ed8ecf2d4fc36863c0c67507b7ed462dac571885643689bbff88dc1ffa3d2a0b
+EBUILD babelfish-9999.ebuild 435 BLAKE2B a091661f9f47b0d53b6db1c30cf6b907675647dde51d24089b91c41877bed820c15dcaf651f5f9895d557f66f4911d7e79539c43ec57c9c3295938c94f5edcd8 SHA512 b5f99bc67286f2681e2c2c796db3e982be47fb4d632fc2ab36deb4d5051b033989992bb41cb9bef6a753582ae75fc3f1f930684692f233bce0b6c885c1c69106
MISC metadata.xml 391 BLAKE2B 50571e0848293806a2da838c5c50c207f0440ce080c594dcee6033d7fd676e58a556d8e0e30e03f83b89fb52e719f9742812e80e69a3ee84ffd205456f62ab9f SHA512 38a98f9e4702451aceba493adeb2284bbcd86246b48fecffdc40d997a588a7db3168df3c966614884a46980c83233aefc62644226b9771250f7c04dd2e215494
diff --git a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
index eafdce09e132..5e101e351f9b 100644
--- a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
+++ b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,3 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
distutils_enable_tests setup.py
+
+PATCHES=(
+ "${FILESDIR}/${P}-py310.patch"
+)
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
index 382197499a3f..78c32c6b1e2f 100644
--- a/dev-python/babelfish/babelfish-9999.ebuild
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 git-r3
diff --git a/dev-python/babelfish/files/babelfish-0.5.5-py310.patch b/dev-python/babelfish/files/babelfish-0.5.5-py310.patch
new file mode 100644
index 000000000000..3acd3c55132e
--- /dev/null
+++ b/dev-python/babelfish/files/babelfish-0.5.5-py310.patch
@@ -0,0 +1,51 @@
+From 7667fb3179e421d4af78821132db8e2557fa2dc6 Mon Sep 17 00:00:00 2001
+From: Hugo <hugovk@users.noreply.github.com>
+Date: Mon, 20 Jan 2020 18:14:46 +0200
+Subject: [PATCH] Fix imports for Python 3.9
+
+---
+ babelfish/converters/__init__.py | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/babelfish/converters/__init__.py b/babelfish/converters/__init__.py
+index feb687b..d27f849 100644
+--- a/babelfish/converters/__init__.py
++++ b/babelfish/converters/__init__.py
+@@ -2,17 +2,22 @@
+ # Use of this source code is governed by the 3-clause BSD license
+ # that can be found in the LICENSE file.
+ #
+-import collections
+ from pkg_resources import iter_entry_points, EntryPoint
+ from ..exceptions import LanguageConvertError, LanguageReverseError
+
++try:
++ # Python 3.3+
++ from collections.abc import Mapping, MutableMapping
++except ImportError:
++ from collections import Mapping, MutableMapping
++
+
+ # from https://github.com/kennethreitz/requests/blob/master/requests/structures.py
+-class CaseInsensitiveDict(collections.MutableMapping):
++class CaseInsensitiveDict(MutableMapping):
+ """A case-insensitive ``dict``-like object.
+
+ Implements all methods and operations of
+- ``collections.MutableMapping`` as well as dict's ``copy``. Also
++ ``collections.abc.MutableMapping`` as well as dict's ``copy``. Also
+ provides ``lower_items``.
+
+ All keys are expected to be strings. The structure remembers the
+@@ -63,7 +68,7 @@ class CaseInsensitiveDict(collections.MutableMapping):
+ )
+
+ def __eq__(self, other):
+- if isinstance(other, collections.Mapping):
++ if isinstance(other, Mapping):
+ other = CaseInsensitiveDict(other)
+ else:
+ return NotImplemented
+--
+2.31.1
+