summaryrefslogtreecommitdiff
path: root/dev-python/awscli/awscli-1.16.148.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-python/awscli/awscli-1.16.148.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-python/awscli/awscli-1.16.148.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.16.148.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/awscli/awscli-1.16.148.ebuild b/dev-python/awscli/awscli-1.16.148.ebuild
new file mode 100644
index 000000000000..12aa770f418b
--- /dev/null
+++ b/dev-python/awscli/awscli-1.16.148.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# requires network access
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/botocore-1.12.81[${PYTHON_USEDEP}]
+ <dev-python/colorama-0.3.9.0[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <dev-python/rsa-3.5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.1.12[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/aws-cli-${PV}"
+
+python_test() {
+ nosetests -vv || die
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED%/}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}