summaryrefslogtreecommitdiff
path: root/dev-python/aws-xray-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
commit9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (patch)
tree2d53ee03e360a9c66a5d8dd8986eee286514336b /dev-python/aws-xray-sdk
parent996a2bda06cb164877d5d952774a6db1b271c2f3 (diff)
gentoo auto-resync : 26:06:2024 - 00:12:24
Diffstat (limited to 'dev-python/aws-xray-sdk')
-rw-r--r--dev-python/aws-xray-sdk/Manifest2
-rw-r--r--dev-python/aws-xray-sdk/aws-xray-sdk-2.13.1.ebuild91
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/aws-xray-sdk/Manifest b/dev-python/aws-xray-sdk/Manifest
index 6f3c58e8eb7f..104b2ea9cdfd 100644
--- a/dev-python/aws-xray-sdk/Manifest
+++ b/dev-python/aws-xray-sdk/Manifest
@@ -1,5 +1,3 @@
-DIST aws-xray-sdk-python-2.13.1.gh.tar.gz 276762 BLAKE2B 3be776b549ff9d0684670b30bbcd3323bf41ea6b8cc6ca2c2de0c3e7b168386ff9776472d53874c30c34fa1e21e890366270639df8319133ca250aa26deb8802 SHA512 6410fe3664ab82fcf6b1770f6e5ec9416d5cf28e9a11940a9dab0816a699696e91befdc642d7c3fdfde37cf6d19a0213e833be831d8cb0ac9645c3e16919d780
DIST aws-xray-sdk-python-2.14.0.gh.tar.gz 276813 BLAKE2B ce9a6c8a3b9acd4cb1e538c75702bebc1e392d350a999e8c609ddb900acadd0ecef11b2ce326786a64a73de3d84b0e18e6f4dd4ad91ece6a13283d727039925c SHA512 e9f7a299e35741a63de999dbd4931b82aab97b4c690e9abec4d25106a4a1b1dbbda605b7ec8541000f97cdcf17fed1283abf8d561db63cc4ac1ed11405458f29
-EBUILD aws-xray-sdk-2.13.1.ebuild 2499 BLAKE2B 3fcb3fd1cf591bcbaf6b435deda8041b0a5cb069af8baae957e026f2ac356e0eaa8b531b4997c32fee6adca362943de1603b66bf7dd0135e037b01c7ed6b7a64 SHA512 2059abc7f54da944f3a6f34c55f0fec9a85a1b4a720575a2427c732354785af9610eb1cd6d485669010497894fb0cdcb1f85abacc53fb03a81c2efb7b5fbf536
EBUILD aws-xray-sdk-2.14.0.ebuild 2499 BLAKE2B 3fcb3fd1cf591bcbaf6b435deda8041b0a5cb069af8baae957e026f2ac356e0eaa8b531b4997c32fee6adca362943de1603b66bf7dd0135e037b01c7ed6b7a64 SHA512 2059abc7f54da944f3a6f34c55f0fec9a85a1b4a720575a2427c732354785af9610eb1cd6d485669010497894fb0cdcb1f85abacc53fb03a81c2efb7b5fbf536
MISC metadata.xml 579 BLAKE2B 3f7aaed38bcceb97fb3597954ca9075ddf7a5718bcac69327be2b99d241c6d8cb0eefd369ca892c8d751703de9067c7eadf19f8c4445334ee8e4952b99fef69e SHA512 f3033cf16f60cae6727f80bd53944972f851579ffef8101cf6fda45e2575696183ec92ea8c994a77bbf3ffc8219be2ae2fae456faabe73a9896bcefddf3b5db5
diff --git a/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.1.ebuild b/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.1.ebuild
deleted file mode 100644
index 311a2a873779..000000000000
--- a/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=aws-xray-sdk-python-${PV}
-DESCRIPTION="AWS X-Ray SDK for Python"
-HOMEPAGE="
- https://github.com/aws/aws-xray-sdk-python/
- https://pypi.org/project/aws-xray-sdk/
-"
-SRC_URI="
- https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
- local -x AWS_SECRET_ACCESS_KEY=fake_key
- local -x AWS_ACCESS_KEY_ID=fake_id
-
- local EPYTEST_DESELECT=(
- # Internet access
- tests/test_patcher.py::test_external_file
- tests/test_patcher.py::test_external_module
- tests/test_patcher.py::test_external_submodules_full
- tests/test_patcher.py::test_external_submodules_ignores_file
- tests/test_patcher.py::test_external_submodules_ignores_module
- # benchmark
- tests/test_local_sampling_benchmark.py
- # Fails, probably because above is ignored
- tests/test_async_local_storage.py::test_localstorage_isolation
- tests/test_async_recorder.py::test_capture
- tests/test_async_recorder.py::test_concurrent_calls
- tests/test_async_recorder.py::test_async_context_managers
- # connects to local mysqld
- tests/ext/sqlalchemy_core/test_dburl.py::test_db_url_with_special_char
- # TODO
- tests/test_lambda_context.py::test_disable
- tests/test_lambda_context.py::test_facade_segment_generation
- tests/test_lambda_context.py::test_put_subsegment
- )
- local EPYTEST_IGNORE=(
- # unpackaged deps
- tests/ext/aiobotocore
- tests/ext/pg8000
- tests/ext/psycopg2
- tests/ext/pymysql
- tests/ext/pynamodb
- tests/ext/sqlalchemy_core/test_postgres.py
- tests/ext/django/test_db.py
- # Internet access
- tests/ext/httplib
- tests/ext/httpx
- tests/ext/requests
- # requires old package vesions
- tests/ext/aiohttp
- tests/ext/django
- tests/ext/flask_sqlalchemy
- tests/ext/sqlalchemy
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}