summaryrefslogtreecommitdiff
path: root/dev-python/aws-sam-translator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
commitd79ab35b7ac170babebe8bc151fe5d037c16285c (patch)
treec774a4913f32e952079ae36fc6afd2dad747837f /dev-python/aws-sam-translator
parent992aa50a54a56c9e705ca4e85d809ec8989d74a2 (diff)
gentoo auto-resync : 22:09:2022 - 17:28:08
Diffstat (limited to 'dev-python/aws-sam-translator')
-rw-r--r--dev-python/aws-sam-translator/Manifest2
-rw-r--r--dev-python/aws-sam-translator/aws-sam-translator-1.51.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/aws-sam-translator/Manifest b/dev-python/aws-sam-translator/Manifest
index 7cd79a86df2d..35e68115d72f 100644
--- a/dev-python/aws-sam-translator/Manifest
+++ b/dev-python/aws-sam-translator/Manifest
@@ -1,3 +1,5 @@
DIST aws-sam-translator-1.50.0.gh.tar.gz 1103467 BLAKE2B 8d9408b7e92a5c515da47075a0722c937223e73dfa99d92d6daf91997a2edf4e1854afb88f7020fdab3457453d1c54ea77cf7e3466ec71ede36bfb3fc9c469fa SHA512 2f8f494218a1ac018893de59e7bede88b73ce446b29cc818d9309275851b080608656f69c422a9b49c885a6e6cbe7f34826f31cf4da9f2ee0667a1663dbee32a
+DIST aws-sam-translator-1.51.0.gh.tar.gz 1107033 BLAKE2B be5d46fa4caa7619c0b959eeec65d0902fdb197369c84c930618398a9b4110c2b1e281c80e63c659be266bb6b2f191495c40578fde73ab31c93bd05906bd55e3 SHA512 d21f3d0b3d4947ad25811f0274e5807089a8d1e2aab76310a80a92f48cfe9ac683bcecea3c833692948f94934be5662cf7585aab0a4a949fcf368901d2e1b9a8
EBUILD aws-sam-translator-1.50.0.ebuild 2255 BLAKE2B 48a47eaf224f0cf84d7d2ee0aa3e3e7ec62844b593e6aa14f6b8b5dc1e46934294fc4454f1c2666dc5d4148a9403c499f3ae43a1d522f5e9a3df929b52613b3f SHA512 8454a7fc31df79581066a995cc7c323e52eb70b29e2c2f9766a4cccba444e910763a51eec5f3920601b7e3d8023807a7558e8e6e083435ff66a0dc3403df187c
+EBUILD aws-sam-translator-1.51.0.ebuild 2257 BLAKE2B fd134b743ab8affdd452652ccabccb31122939c458dcd52f2019a0290c4a2725ac5a0b10fd102e71929f41d17037a2b7f10c3ef2019a022b94d5a80b79e691fc SHA512 756fb5f4baa0b7647d7af262ff895fcc5605cfe8fca0d8089f90d62e5ff846b60d0432a8df5e4a47487b289f10b20b3b4e7f9ec8a1927cc6b17cdbb245cec13b
MISC metadata.xml 603 BLAKE2B 89556267393186cf69a585c58efeb6fa599bfb42ef221bea955ea807a28edee89036a2ee0d0ca81ae55d96702a01b171b837754dabf38047ecc2789157bb7116 SHA512 106b6d241eadf7807dadf03329073703f8b51e7443eddc4db8752878b6dd84cc4357689cd4b796b3a083192e9d98eacbe9e7b8af0273160c7b89846e78230a88
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.51.0.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.51.0.ebuild
new file mode 100644
index 000000000000..4194237c6fc3
--- /dev/null
+++ b/dev-python/aws-sam-translator/aws-sam-translator-1.51.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="
+ https://github.com/aws/serverless-application-model/
+ https://pypi.org/project/aws-sam-translator/
+"
+SRC_URI="
+ https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/serverless-application-model-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/boto3-2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.19.5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/validator/test_validator_api.py::TestValidatorApi::test_errors_13_error_definitionuri
+ tests/unit/test_region_configuration.py::TestRegionConfiguration::test_is_service_supported_positive_4_ec2
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_success_one_app
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_throttling_doesnt_stop_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sleep_between_sar_checks
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_unexpected_sar_error_stops_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_and_on_after_transform_template::test_time_limit_exceeds_between_combined_sar_calls
+)
+
+python_prepare_all() {
+ # remove pytest-cov dependency
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ # deps are installed by ebuild, don't try to reinstall them via pip
+ truncate --size=0 requirements/*.txt || die
+
+ distutils-r1_python_prepare_all
+}