summaryrefslogtreecommitdiff
path: root/dev-python/autoprop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/autoprop
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/autoprop')
-rw-r--r--dev-python/autoprop/Manifest3
-rw-r--r--dev-python/autoprop/autoprop-1.0.2.ebuild18
-rw-r--r--dev-python/autoprop/metadata.xml24
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/autoprop/Manifest b/dev-python/autoprop/Manifest
new file mode 100644
index 000000000000..b882a73a8739
--- /dev/null
+++ b/dev-python/autoprop/Manifest
@@ -0,0 +1,3 @@
+DIST autoprop-1.0.2.tar.gz 11040 BLAKE2B b53bdbf79947002a0c319fa84c6033908948365d18a85dd2fd4139bff2125752e0bc3fc8f19e5d38c06cdc089f423cc8a720b8040593cfbda9c04c84b7cd4ffd SHA512 281c30fded6d79ed3bbb0de5b7a37c2cc5b985a4980974503b5bbb5940cd22f3c09c3b3d9d513d5cb95239519519b277bf43536407fedb593a43122ee32a8db6
+EBUILD autoprop-1.0.2.ebuild 433 BLAKE2B 2e3d456c4cf323d3a3641875011b9eb5213e4cd02fac8a9504a2dfbcb6ec476c60f103d36a0ca71c4cd93ae1f61a787349207bb807ccfee333a742b799f8cc07 SHA512 d1ac6c4ef607d2b53d6bf659175df94af85068f8e7d34d5899a0e1e21796e30dbe9e38f58e4bbd4504817fca9ca595d1088c4ede94a8b22d37cc466be938454f
+MISC metadata.xml 1272 BLAKE2B 067d1a9a446ceaba7dd463cbafeccaece90033ba376056f5da637fae097c08bda975e83b19d0d27e98e6490cb82c879c4425aed277f62a0e78ee42761a80159f SHA512 3342440e05c49ad5e5bc2144e613042145761594e20b3b1736d2f13964636f0260ba0398b71517d207b98cf51f51843f56c38f34f88cb588bd2a88212e187d4f
diff --git a/dev-python/autoprop/autoprop-1.0.2.ebuild b/dev-python/autoprop/autoprop-1.0.2.ebuild
new file mode 100644
index 000000000000..03d8f7babb8a
--- /dev/null
+++ b/dev-python/autoprop/autoprop-1.0.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="https://github.com/kalekundert/autoprop https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/dev-python/autoprop/metadata.xml b/dev-python/autoprop/metadata.xml
new file mode 100644
index 000000000000..3b6fefbcfe32
--- /dev/null
+++ b/dev-python/autoprop/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Properties are a feature in python that allow accessor functions (i.e. getters and setters) to masquerade as
+ regular attributes. This makes it possible to provide transparent APIs for classes that need to cache results,
+ lazily load data, maintain invariants, or react in any other way to attribute access.
+
+ Unfortunately, making a property requires an annoying amount of boilerplate code. There are a few ways to
+ do it, but the most common and most succinct requires you to decorate two functions
+ (with two different decorators) and to type the name of the attribute three times.
+
+ The autoprop module simplifies this process by searching your class for accessor methods and adding properties
+ corresponding to any such methods it finds.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kalekundert/autoprop</remote-id>
+ <remote-id type="pypi">autoprop</remote-id>
+ </upstream>
+</pkgmetadata>