summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-26 09:56:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-26 09:56:45 +0100
commitf3471ff11210507b38c09f0e57df1bd601f629a5 (patch)
tree9931bc74efae95f78cd0270fde107c779d2dd482 /dev-python/autopep8
parent5e5fb5c6d1e0af4b12dbee7de7d095df902ce2b6 (diff)
gentoo auto-resync : 26:08:2023 - 09:56:44
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest2
-rw-r--r--dev-python/autopep8/autopep8-2.0.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index c12599ce24a7..1c453a056ef0 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,6 @@
DIST autopep8-2.0.2.tar.gz 116154 BLAKE2B 1b6830f9cb8a4384898273411f6b03cf3e3c0e45e2c56fa2bb134f3567cc06459a8123e660db9252f8d7cd15835d70e54c0155f146191be64ffbafaaa808244d SHA512 09471827d18ca0c691bc524e0639a416d1a4418ddda1cb88f50e5c5302e75e7014751e659e26439c22317db21588fbd956c94299cef44e2c47771df38de94be3
+DIST autopep8-2.0.3.tar.gz 116499 BLAKE2B f43476babe717ccd1d8ea363dc00e8a1227433078c89662c92097b2e569c9da46ad14af4e42982289bf6ec6cfc88f4db233b638dcf89f882fd7c4650f3f70160 SHA512 0007d6c6a17f21e1b4e00d1b69d83cac6db50a4c17ae351a429275958adcbb1d014e0f7e7e966239cc47388cb15ec07a3569f1254c1f16ebf6fb7d43fcfe57e6
EBUILD autopep8-2.0.2.ebuild 1141 BLAKE2B 68ee3cfb6b02a8e49be685a6239b151946bb9a8ea6a1e57315582e9e90b10ac45af6d1b6312fe947b0dd21763141905b53f633dbcf779ff07c3e3318d98740bc SHA512 08f6da3eb29eea4d39e6dd569d7ea1d173cd3a38672ae289b52a0e5951a978da564b76e2d0a5d23836e23bb4efa9c781291f22f03df59cbbb36bcd99228c2b4d
+EBUILD autopep8-2.0.3.ebuild 1146 BLAKE2B 7ddf89d6f682dd703bac846a11281dd5fe53fd384e88bff6b3a21a4a3a43186f1ec29dbea0919c0fe0d1f71d79e758ef3c8bab9a36fc38aef95a1e0c89396dc8 SHA512 7499022cc7e0015a4326623157078cd38568f1bbfeafe17c6040b5f12542a0e53447012274309294fb4c5d93f702829a9da772509f17582ff9702aa437d3f9ac
EBUILD autopep8-9999.ebuild 808 BLAKE2B 0a10876631074874bf1890aa1537e7b92a66f17a52acaa7d46f6e5038f5ce038f4fd33a50dc2caa9cd9ca88bf7aca764b416430aea1f8ee4251a65a5ca88f10c SHA512 98c8b5b784d2007de45c6817142d1c63e3d415d7d817edf57818ec6051256733abe32e32eb24e843ea1631d0a796718b74b5fb53147eafcbe0991d4e011b792c
MISC metadata.xml 404 BLAKE2B e9442968d195e1605d55b880cf29f4a2945f67c57c0d7d0325e19c0ccf60cac0ac3e68115a0285f87068482163f537abc1d75bddfdc6ae860c8c52c375147fdc SHA512 3e0b8a6ee869086166bb670a73189ca681729276cc7897666127b7e25b3a252aa2e80da5fd4dbb43d101a439d12f146ba0ba61bebf30a87a97f1030325f1aeab
diff --git a/dev-python/autopep8/autopep8-2.0.3.ebuild b/dev-python/autopep8/autopep8-2.0.3.ebuild
new file mode 100644
index 000000000000..1d0c3278faab
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to deprecation warnings
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
+ )
+
+ epytest
+}