summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/autopep8
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest2
-rw-r--r--dev-python/autopep8/autopep8-1.5.5.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 3ccd134837f0..51edae27565b 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,6 @@
DIST autopep8-1.5.4.tar.gz 121471 BLAKE2B 4d9d4d0de94757573ad56636d92983d0bedfb2c7a3f25a47d8dba9c78c4e0752aa2ea0cd43f93d9cf37e434178cf89ad6c98b2af3a07f2490147c87a95ff610a SHA512 e613295d080149028361715f748fc9db1b7fc6212ca4e117594a10c3924a67eaad6ff8d94cfcf2c3dea087e0aa1ce6bcadc1b4eb3f07915daa5b002a09913f59
+DIST autopep8-1.5.5.tar.gz 117991 BLAKE2B 74e9bfed663d68f4a73088fccd879c538d40c564e7527b067d549a15361dfba2adcb853a8895fc61da50972f947ce23900f8067f5b8e715f73d6a80c6c27ef5b SHA512 9982271805131a7330d4a2a46eda65c05f079925393686f2df7eb92dc9e172003f9d788663cb8c0c8849dbae4f64c518c310eb65c3df308a12700abab084c39c
EBUILD autopep8-1.5.4.ebuild 848 BLAKE2B 611f5c07e00f65d96e6b9937c3901a1e8eadbd5935305930f5cd51dda81d08161a936a826efc84e360b3200c642e3eb0e17fd13129596a8ba410734090bafaf9 SHA512 e2676d967fd0e231c6a10ea09f779bd9248d531e881d35c841f6062058d2bcb3a683745076db4c2a468752d7a15c5c5fa34e3c307fe3153cf63aac8aca9f1c37
+EBUILD autopep8-1.5.5.ebuild 852 BLAKE2B 31fa597daf60388aeb3e0bd8899e432509819048722dd88e29f771b088961dfd001e1855350e0fc87c5100eee3a04e9425b3ba4b90ff7a17723e8046981cc9ae SHA512 3f9340ec088580d6be94f60054740ed70a4c3f024a2f441c0c880d279892497749af8ea94074cbe10458eaba4652f7d2e33b9f008f85f5d7d624fdd47bb41150
EBUILD autopep8-9999.ebuild 852 BLAKE2B 8fff8cfdccb97703fa9d3503c9c3c649de315241d0791f1927161e3385cfa0945566b3ca78c04a56a147f2a4f7fbff603810b98bba1f6251c821bb6e004c7020 SHA512 13ca0fb94ff41a20f23e416438c90205123f522906732d6b43d759b87d70f5ba6d7479512d695440180c2a8b1744e7486d5d8f10a81cf1d77b23586fb5be564f
MISC metadata.xml 403 BLAKE2B b84ac94eda3fac9977c2a936d006626b0fbc918c24d8f08f4b7620b778ea5ffec298945bbe6baf5353fc00888ee97c7f3c48493ab1c83ebe1586a9196da13a59 SHA512 7e2fd3edd7e82fa2474441a0e54ebbca38dd95f2dba7ba717fd839cf11bd21cb00d5ee56c7b8dc1b377e24a33b098d2932cc06de6c367e1c812b448a9395f18a
diff --git a/dev-python/autopep8/autopep8-1.5.5.ebuild b/dev-python/autopep8/autopep8-1.5.5.ebuild
new file mode 100644
index 000000000000..daf7a5d94067
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.5.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py