summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
commitad77dc19e91d2c023f80e11e8974536d80e3a743 (patch)
tree42bb312ab0eb61fd94103e3eddb65b134f6be5a4 /dev-python/autopep8
parent6de28447d66e6c47ee682740b840cdb67244d4b1 (diff)
gentoo auto-resync : 05:04:2023 - 11:25:00
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest4
-rw-r--r--dev-python/autopep8/autopep8-2.0.1.ebuild47
-rw-r--r--dev-python/autopep8/autopep8-2.0.2.ebuild2
3 files changed, 2 insertions, 51 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index d9b132219c24..c12599ce24a7 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,6 +1,4 @@
-DIST autopep8-2.0.1.tar.gz 115905 BLAKE2B 9dde8d702a0b21fb1457e08120dca805e2b46e3e5284e5d98932ff93afc4c0ac8dbc60215f35b64d4a308d6748df1411c2979d8fa1f4949b1dbe213bf19de9dc SHA512 cc0e8e5b7228ba9b37adaa3b2689a5e1ad04eb84366c5300d7a220b1593a64e4f1dc332750f8ca53935dec6a3ea1d07cae5615373e44da357a980d9763bbc3f1
DIST autopep8-2.0.2.tar.gz 116154 BLAKE2B 1b6830f9cb8a4384898273411f6b03cf3e3c0e45e2c56fa2bb134f3567cc06459a8123e660db9252f8d7cd15835d70e54c0155f146191be64ffbafaaa808244d SHA512 09471827d18ca0c691bc524e0639a416d1a4418ddda1cb88f50e5c5302e75e7014751e659e26439c22317db21588fbd956c94299cef44e2c47771df38de94be3
-EBUILD autopep8-2.0.1.ebuild 1180 BLAKE2B 78ce747c4104f4b977d68155ea8383c4c7d1dbae5aa30399461f6382345c38402474478d4c706d4eeb5eeabec66af656e4705cdd58d36309dcd7e1b20a770825 SHA512 3e3abb02b9768c95426e7166ec94af338b53532cea1984f7db3d1c899fadcebb0d5c638709a2e7178c62e5b9828a4b3f9a8460019a69cf32cdb55f3d073e90ac
-EBUILD autopep8-2.0.2.ebuild 1145 BLAKE2B 15afa6e395d085649cbfe78e6d9443e5a3559c32a7327198c61f94c36a7e3662ec1f061671b0910332df8467229360d68e68c40e40d0049669fc958bc01ddead SHA512 e1b2d7c2534b85cae674b0a4140e906fe85c6a64eb2ae246a9f5193a2db14a3c50fe66327df15078471ca504dad26cc08a5cfef1398026fba7b4f96b5049967c
+EBUILD autopep8-2.0.2.ebuild 1141 BLAKE2B 68ee3cfb6b02a8e49be685a6239b151946bb9a8ea6a1e57315582e9e90b10ac45af6d1b6312fe947b0dd21763141905b53f633dbcf779ff07c3e3318d98740bc SHA512 08f6da3eb29eea4d39e6dd569d7ea1d173cd3a38672ae289b52a0e5951a978da564b76e2d0a5d23836e23bb4efa9c781291f22f03df59cbbb36bcd99228c2b4d
EBUILD autopep8-9999.ebuild 808 BLAKE2B 0a10876631074874bf1890aa1537e7b92a66f17a52acaa7d46f6e5038f5ce038f4fd33a50dc2caa9cd9ca88bf7aca764b416430aea1f8ee4251a65a5ca88f10c SHA512 98c8b5b784d2007de45c6817142d1c63e3d415d7d817edf57818ec6051256733abe32e32eb24e843ea1631d0a796718b74b5fb53147eafcbe0991d4e011b792c
MISC metadata.xml 404 BLAKE2B e9442968d195e1605d55b880cf29f4a2945f67c57c0d7d0325e19c0ccf60cac0ac3e68115a0285f87068482163f537abc1d75bddfdc6ae860c8c52c375147fdc SHA512 3e0b8a6ee869086166bb670a73189ca681729276cc7897666127b7e25b3a252aa2e80da5fd4dbb43d101a439d12f146ba0ba61bebf30a87a97f1030325f1aeab
diff --git a/dev-python/autopep8/autopep8-2.0.1.ebuild b/dev-python/autopep8/autopep8-2.0.1.ebuild
deleted file mode 100644
index 807955f05f3e..000000000000
--- a/dev-python/autopep8/autopep8-2.0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # fails due to deprecation warnings
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
- )
-
- epytest
-}
diff --git a/dev-python/autopep8/autopep8-2.0.2.ebuild b/dev-python/autopep8/autopep8-2.0.2.ebuild
index f3389447202d..05e242d04220 100644
--- a/dev-python/autopep8/autopep8-2.0.2.ebuild
+++ b/dev-python/autopep8/autopep8-2.0.2.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
inherit pypi
- KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"