summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/autopep8
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest4
-rw-r--r--dev-python/autopep8/autopep8-1.5.4.ebuild29
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild11
3 files changed, 38 insertions, 6 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 8f00cfeb7513..0c4ea5cfc2b7 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,6 @@
DIST autopep8-1.4.4.tar.gz 114796 BLAKE2B 0eef2550e2e13a79e4c3199dae119ed49b13056d9bbd98be5d9e4c7d0288d12bf6ad30162c0e4c485f6de9b47b4b6ecfe92dcb278f2cb265b75e395bdda77aa8 SHA512 06822df7cd02c68980965c1fd987dec03785e155554ff0f735dc707c4de99b4d152b0d092e21017ec5d9176b33bcf22f3ef2b0986f38faebab0928443eca4d32
+DIST autopep8-1.5.4.tar.gz 121471 BLAKE2B 4d9d4d0de94757573ad56636d92983d0bedfb2c7a3f25a47d8dba9c78c4e0752aa2ea0cd43f93d9cf37e434178cf89ad6c98b2af3a07f2490147c87a95ff610a SHA512 e613295d080149028361715f748fc9db1b7fc6212ca4e117594a10c3924a67eaad6ff8d94cfcf2c3dea087e0aa1ce6bcadc1b4eb3f07915daa5b002a09913f59
EBUILD autopep8-1.4.4.ebuild 822 BLAKE2B 166a16771249241a262188451b1d0ffdd629bc8c6755b804a7f4bd1bf103bb99dfdcdcf96e1ff651b6442bcfb847524809e58724d493ee01d483c53c1c9196cd SHA512 ee8f3ef92a8454b7d51a56e42c5373f5ff3861d5a92518926dc96ee83c2315e41fc5605fb737053bb3db2661a6aa378dc4d507c4167c3675a872653aa05d7ac6
-EBUILD autopep8-9999.ebuild 799 BLAKE2B a0a3cb93be6e0d566e42a7f92906de125f88e7519c3c19852977567e08e44c39059af4ca53c6c6741689d9633df6317d0e3bf48fc29ba137ebf66d0778977348 SHA512 79ad3a98848af6ca1cf60a4dda33b6adf41e5e0fd9e6ef13b3c04bf61ce060c6111962d35d0e894e909fabb9a336cb73b06674c6a573baada40a22de5b803dcf
+EBUILD autopep8-1.5.4.ebuild 819 BLAKE2B 751eefd61bf46d0fadccaad7e1383dbc17580d9e50821370044ea721328517c01e9e39d05da3435130dba66e7969b56522d65ab94a3d3f4a13345ebcc57882ae SHA512 bec6a094ae8c90e8e03095e9496d896a98c26e50cfe22ec7df5ba392273894aff2aeca1426e33703e63d73db833e4955ead024ac0858db5dc840fee7d195c1da
+EBUILD autopep8-9999.ebuild 819 BLAKE2B 751eefd61bf46d0fadccaad7e1383dbc17580d9e50821370044ea721328517c01e9e39d05da3435130dba66e7969b56522d65ab94a3d3f4a13345ebcc57882ae SHA512 bec6a094ae8c90e8e03095e9496d896a98c26e50cfe22ec7df5ba392273894aff2aeca1426e33703e63d73db833e4955ead024ac0858db5dc840fee7d195c1da
MISC metadata.xml 378 BLAKE2B c45e6a1e950f4288d6bf63969fb59c426a483c9e27294b6aa18c85d827f0cbce3cad2111852f6c7bb9347a17650b92b98fc3234989742459c57652fb6600adcb SHA512 e7ac8c3772bcdef589f909947f23d6c97d09ca98eb3aafbd88cf4af53ed56c12f85741e0d8f872ffceefd59012e11f4c98939b0daa79590255685cbbf04acf80
diff --git a/dev-python/autopep8/autopep8-1.5.4.ebuild b/dev-python/autopep8/autopep8-1.5.4.ebuild
new file mode 100644
index 000000000000..4ebce4805b38
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index 90456b8815b5..4ebce4805b38 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -15,14 +15,15 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"
SLOT="0"
-RDEPEND=">=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
distutils_enable_tests setup.py