summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
commit9afce155a599e5f4518f3c7913b6424ac13be12e (patch)
tree60420eafdcf940c0e4555d9aa8e4e9017a646344 /dev-python/autopep8
parenteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (diff)
gentoo auto-resync : 06:11:2023 - 16:19:27
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest4
-rw-r--r--dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild51
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild4
3 files changed, 56 insertions, 3 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 6308119b0303..c9dd4e2c7456 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,6 @@
DIST autopep8-2.0.4.tar.gz 116472 BLAKE2B c6e6d207e9e27db450b74fe63fc3c8dce1e6729e0c86046e3efb2a7e749ff402e4cb33062a10c49db7a5f158b12df35088686425a9d822a32b8a4fb6185aae7c SHA512 2c3731d328d0128b4e93c9cb05d730cdf4e08cb18b73ca0de3ac24462feb3e1e61c805ce4cef67f0df2db04773657d0efae70cbca9a67fa5d2790b07daeafeac
+DIST autopep8-2.0.4_p20231027.gh.tar.gz 146180 BLAKE2B 3818423c9683157df0c3ed905a225228da7ca44a361247aecbc84b70bd5476a148c6ceb38598b84ff337bf66b1fadcbec47c79738954d90fe1f04f31a467441a SHA512 28c88acd0863d7f6a7333150ce9b916e4776eefacc7eeb7c4de14a3c823c9331fb15fef03f2288ae921ddef37c19191a6550b152df6331d075217908ab1b3a7f
EBUILD autopep8-2.0.4.ebuild 1142 BLAKE2B 2a455b4da6edcf164a0b8fcd29ad30334ffd940980c667944ebbd17721980fb71922815a8e6a8b621b211d3c2c5f1fbe3239034a1ca8c1d91bd7959d92af0d98 SHA512 46fb86ba60da4fcc1b17ead6732767344dc7adad3fd07a5464d9842f73a218364aea915bd8fcbd61579fd3bd8734837f82341d935aa78ffca459c8bf818ccd3e
-EBUILD autopep8-9999.ebuild 808 BLAKE2B 0a10876631074874bf1890aa1537e7b92a66f17a52acaa7d46f6e5038f5ce038f4fd33a50dc2caa9cd9ca88bf7aca764b416430aea1f8ee4251a65a5ca88f10c SHA512 98c8b5b784d2007de45c6817142d1c63e3d415d7d817edf57818ec6051256733abe32e32eb24e843ea1631d0a796718b74b5fb53147eafcbe0991d4e011b792c
+EBUILD autopep8-2.0.4_p20231027.ebuild 1304 BLAKE2B a184d0cccb8e3e605dfb90c311e6f576fffed380adabf639b75a595cb3a9085615790ffc848cd2c23ae21745f9d3ff2ff48f6e27b698abf516b1bd0ff5d13903 SHA512 d9aa6fda4a560b9b69cca5191ddcd641a6d59a26de5d1277864321c82ca90a4ef50a4980ee2abe8bc91f1c770d3ad6386d72c765f92d60acee6aa476218dbedb
+EBUILD autopep8-9999.ebuild 804 BLAKE2B 639958a931b30f46cab9c6f28845f221f7bbd3a32101418cb442bc2b37a1ee5c843a409c16370e04ce1fd9188eda006d2ed6d32d22fbbd13a46191a55efb540d SHA512 2de23197bb23add952003d6ebb737fd346b58897ffca8f11caa98e4e5de88b412dbdbcf84bc374f22db10d75a520796b07a3c7af3cb3cb48c9a64a419f0ca2da
MISC metadata.xml 404 BLAKE2B e9442968d195e1605d55b880cf29f4a2945f67c57c0d7d0325e19c0ccf60cac0ac3e68115a0285f87068482163f537abc1d75bddfdc6ae860c8c52c375147fdc SHA512 3e0b8a6ee869086166bb670a73189ca681729276cc7897666127b7e25b3a252aa2e80da5fd4dbb43d101a439d12f146ba0ba61bebf30a87a97f1030325f1aeab
diff --git a/dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild b/dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild
new file mode 100644
index 000000000000..05e47b6ddcdc
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ COMMIT="af7399d90926f2fe99a71f15197a08fa197f73a1"
+ SRC_URI="
+ https://github.com/hhatto/autopep8/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to deprecation warnings
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
+ )
+
+ epytest
+}
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index ee34bcad54d2..1d564bd34c07 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -29,7 +29,7 @@ RDEPEND="
>=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
+ ' 3.10)
"
distutils_enable_tests pytest