summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/autopep8
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest2
-rw-r--r--dev-python/autopep8/autopep8-1.5.6.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 35d5a4c68014..cf241b8f512a 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,6 @@
DIST autopep8-1.5.5.tar.gz 117991 BLAKE2B 74e9bfed663d68f4a73088fccd879c538d40c564e7527b067d549a15361dfba2adcb853a8895fc61da50972f947ce23900f8067f5b8e715f73d6a80c6c27ef5b SHA512 9982271805131a7330d4a2a46eda65c05f079925393686f2df7eb92dc9e172003f9d788663cb8c0c8849dbae4f64c518c310eb65c3df308a12700abab084c39c
+DIST autopep8-1.5.6.tar.gz 121134 BLAKE2B aefeb4cc53ac66fb6eaef4d7af286d6249e7139e5409fe6f6b3568f0c6216d758dd73a950d043e36b6f19cf5de83f62e28ca318c45a7e40ffdeac0f7a9e06cdf SHA512 d283c3e2021025097c6b2f95faf7db12664b7d1f69f82acf9fe94e20fbd49cfcb28ad47437aa3148503c59cf5c2690a842fd795f869731290c80dc9feb86637b
EBUILD autopep8-1.5.5.ebuild 848 BLAKE2B 611f5c07e00f65d96e6b9937c3901a1e8eadbd5935305930f5cd51dda81d08161a936a826efc84e360b3200c642e3eb0e17fd13129596a8ba410734090bafaf9 SHA512 e2676d967fd0e231c6a10ea09f779bd9248d531e881d35c841f6062058d2bcb3a683745076db4c2a468752d7a15c5c5fa34e3c307fe3153cf63aac8aca9f1c37
+EBUILD autopep8-1.5.6.ebuild 852 BLAKE2B d5bb196ed46298a4ddfd92d11283bfcb934926225eb387a5c3f1f2204ef1217a0423b7a1679342af6dec7b8946ed6f9e106dded2d974be06531bfa2b30561bab SHA512 d1348c3d901f9587052fb2328ba788ec5b19be9a38b3cf33a1a7c9bdb4e1ffeb72b30c7a86fd9b50e6f752048b05c46ca03307a0e012608a4199a3ee971e5da7
EBUILD autopep8-9999.ebuild 852 BLAKE2B 8fff8cfdccb97703fa9d3503c9c3c649de315241d0791f1927161e3385cfa0945566b3ca78c04a56a147f2a4f7fbff603810b98bba1f6251c821bb6e004c7020 SHA512 13ca0fb94ff41a20f23e416438c90205123f522906732d6b43d759b87d70f5ba6d7479512d695440180c2a8b1744e7486d5d8f10a81cf1d77b23586fb5be564f
MISC metadata.xml 403 BLAKE2B b84ac94eda3fac9977c2a936d006626b0fbc918c24d8f08f4b7620b778ea5ffec298945bbe6baf5353fc00888ee97c7f3c48493ab1c83ebe1586a9196da13a59 SHA512 7e2fd3edd7e82fa2474441a0e54ebbca38dd95f2dba7ba717fd839cf11bd21cb00d5ee56c7b8dc1b377e24a33b098d2932cc06de6c367e1c812b448a9395f18a
diff --git a/dev-python/autopep8/autopep8-1.5.6.ebuild b/dev-python/autopep8/autopep8-1.5.6.ebuild
new file mode 100644
index 000000000000..d3ff82ca62d1
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py