summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 02:06:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 02:06:14 +0000
commit5987fa693ef880163ebde423615a177cb5bda20e (patch)
tree643ae0ed032ef417c538f8d04da516b9c2fa2a7d /dev-python/autopep8
parent41e056b08e4c5c8d6e78407a5586afa52867fd5f (diff)
gentoo auto-resync : 17:02:2023 - 02:06:14
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest3
-rw-r--r--dev-python/autopep8/autopep8-2.0.0.ebuild42
-rw-r--r--dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch28
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 583c6a507a22..f672ef950308 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,7 +1,4 @@
-AUX autopep8-1.6.0-lib2to3-deprecation-pytest.patch 1094 BLAKE2B fbca6a4c342f525cf20487551133d9a0279a00ed0de4439d3fe73736afaa70c4ae3d3ba2c2960d87423d2b6b98fb08f6c3604e17c9078dc9880f91cf090509fc SHA512 7f4204495c5ca0acfb3cf411c17cf4cdf6e340d84ff4a8a494ff33494923813e73b8bf55db975bd4f6c0fed1abb7669bb77c89be1512e9d8629cbb5898999440
-DIST autopep8-2.0.0.tar.gz 117507 BLAKE2B 8722b19454f47d0b960e3cc0e18ff3d6150ead009630047ecd1ce9001ea6f6d68595f80d7ad1087bddd2993e95d0634d63495b1d43dee095d114535bf632d1bf SHA512 883b79f7011a374a2ef88073a45748268a20449a3bc8da519c036c71700352dd8c4accc60fcb592f1a53ceac06984fcbe6ede8a272bc718c2b79873be5f35dd8
DIST autopep8-2.0.1.tar.gz 115905 BLAKE2B 9dde8d702a0b21fb1457e08120dca805e2b46e3e5284e5d98932ff93afc4c0ac8dbc60215f35b64d4a308d6748df1411c2979d8fa1f4949b1dbe213bf19de9dc SHA512 cc0e8e5b7228ba9b37adaa3b2689a5e1ad04eb84366c5300d7a220b1593a64e4f1dc332750f8ca53935dec6a3ea1d07cae5615373e44da357a980d9763bbc3f1
-EBUILD autopep8-2.0.0.ebuild 989 BLAKE2B bf6244fded9a20943273d4d7d6f04532ca64733641ed4ae5e5f37cf6df41ed6e25424a83f4614be54d6b202d7e8a0a36f09cecc1f239751cd2473e986055d44c SHA512 ebedeeaa6732a9a6bf452ecbcddd7b9c419873075d3c570995ead6c29125cb9a0566ebc622b47fa40f684032970744009915de002ed612639af552c357245cf3
EBUILD autopep8-2.0.1.ebuild 1173 BLAKE2B 4b17cbbf0b1dfe7d8561085c0ba0a952ffb6ad994c651a82f39f8c164c2d5924335b1ad4d2cdad7e634d89d75d27289741f554f96a1a0ba0ab9e6f885577f9f8 SHA512 c22d2b89c554009cda96e996ca3af0fd66ea5def0f0ce5923376f1b48568c443cf3f9cb978d6ac20870a5bb7a51c8e6364c29dc95b389a8963828b20e1451f9c
EBUILD autopep8-9999.ebuild 840 BLAKE2B c0e5ab9fbd3bb4e14c737f882a63b8973049821340fb859b55106dd58802188b05befcda62d9a98099d43c482db7abd7dd9051b5ee099d17af131071aa6478ea SHA512 5f6b7b14583511a5c86bad607465a9e2b6f2999cadd6e2bfebd0082db3eafcb5da36bb9a7f09e244f090d932f3e00542340c6914ed3168aa66aafccee46bb146
MISC metadata.xml 404 BLAKE2B e9442968d195e1605d55b880cf29f4a2945f67c57c0d7d0325e19c0ccf60cac0ac3e68115a0285f87068482163f537abc1d75bddfdc6ae860c8c52c375147fdc SHA512 3e0b8a6ee869086166bb670a73189ca681729276cc7897666127b7e25b3a252aa2e80da5fd4dbb43d101a439d12f146ba0ba61bebf30a87a97f1030325f1aeab
diff --git a/dev-python/autopep8/autopep8-2.0.0.ebuild b/dev-python/autopep8/autopep8-2.0.0.ebuild
deleted file mode 100644
index 162c3d53396b..000000000000
--- a/dev-python/autopep8/autopep8-2.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test require in source build
- test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
-)
-
-PATCHES=(
- "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
-)
diff --git a/dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch b/dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
deleted file mode 100644
index 9aadf2758c0c..000000000000
--- a/dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/test/test_autopep8.py 2022-07-01 16:53:14.197393816 +0300
-+++ b/test/test_autopep8.py 2022-07-01 17:26:07.740358186 +0300
-@@ -5729,7 +5729,11 @@
- list(AUTOPEP8_CMD_TUPLE) + [filename, '--in-place'],
- stderr=PIPE,
- )
-- _, err = p.communicate()
-+ _, error = p.communicate()
-+ if b'DeprecationWarning: lib2to3 package is deprecated' in error:
-+ err = bytes()
-+ else:
-+ err = error
- self.assertEqual(err, b'')
- self.assertEqual(p.returncode, autopep8.EXIT_CODE_OK)
-
-@@ -5741,7 +5745,11 @@
- list(AUTOPEP8_CMD_TUPLE) + [filename, '--in-place'],
- stderr=PIPE,
- )
-- _, err = p.communicate()
-+ _, error = p.communicate()
-+ if b'DeprecationWarning: lib2to3 package is deprecated' in error:
-+ err = bytes()
-+ else:
-+ err = error
- self.assertEqual(err, b'')
- self.assertEqual(p.returncode, autopep8.EXIT_CODE_OK)
-