summaryrefslogtreecommitdiff
path: root/dev-python/autopep8/autopep8-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-28 09:59:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-28 09:59:10 +0100
commit8eb973cc2247ee4fe34e4d907fdc6cf5b94709e3 (patch)
tree0834df6dbfa798c2c138698cc26cf6a731fe937e /dev-python/autopep8/autopep8-9999.ebuild
parente5985b8e66b3b43c34328efb47b9b12e8ce5a690 (diff)
gentoo auto-resync : 28:10:2022 - 09:59:10
Diffstat (limited to 'dev-python/autopep8/autopep8-9999.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index bb50e6c643bd..b201d023a72a 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -3,14 +3,17 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
inherit git-r3
@@ -23,8 +26,17 @@ LICENSE="MIT"
SLOT="0"
RDEPEND="
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
dev-python/tomli[${PYTHON_USEDEP}]
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test require in source build
+ test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
+)
+
+PATCHES=(
+ "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
+)