summaryrefslogtreecommitdiff
path: root/dev-python/autopep8/autopep8-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/autopep8/autopep8-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/autopep8/autopep8-9999.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index 18e92a67fb4f..ae057e4cf2d2 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -20,14 +20,9 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="test"
-RDEPEND="
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
-python_test() {
- "${PYTHON}" setup.py test || die
-}
+distutils_enable_tests setup.py