summaryrefslogtreecommitdiff
path: root/dev-python/autopage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/autopage
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/Manifest4
-rw-r--r--dev-python/autopage/autopage-0.5.1.ebuild (renamed from dev-python/autopage/autopage-0.5.0.ebuild)16
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-python/autopage/Manifest b/dev-python/autopage/Manifest
index 151c3490ffe1..9d11345c7f3a 100644
--- a/dev-python/autopage/Manifest
+++ b/dev-python/autopage/Manifest
@@ -1,3 +1,3 @@
-DIST autopage-0.5.0.gh.tar.gz 21403 BLAKE2B 1c20123bd7ac9dcfc53d5531ea5cec5dcb2d4b8f4c433ab958b96b769540084989ee841f963d24d1b01c3c4deed9933ab213e3838a898a8fc3261096a272d83d SHA512 b40bf0c432a8ecf82f56cf9679191bf13e5fbf478f1236d197df05e29ac27a1d33bffbf3f66fedbf93548e7314ee1a8f1687fa7c696b35f944f8f5dfd2b2dd19
-EBUILD autopage-0.5.0.ebuild 693 BLAKE2B d96b147c11ab6171146efe85077ad01a009786321131971abf201fb997cff62941cf8621c7f04591719b7aad9135ca12a9833122750b1fd253117175b95c0649 SHA512 1547d199345f1069ed39913456b4252c0c9ec48780baafcbae8a43a98e8512c1b48dcb8230c3c382ee66148dba12c30e02d12984e747efd5b87cee7a4a523b45
+DIST autopage-0.5.1.gh.tar.gz 21406 BLAKE2B 45d67443fa882d6f824ea71a8f9d20eb1ae789a271d84dc566a2535de631b5ce644aa28f51c5be1db818194e39628b6526ac087cd6eccc425132f15fafda10e9 SHA512 3d6e10c222566fd5f5e07e3247ebe19ce7ffe3b4baf9948741ee9a8aaafbefb0fcfaf4b26f0a4a6392615e73c7e8539c9bcbff1112a291c193c0b653f33e8657
+EBUILD autopage-0.5.1.ebuild 707 BLAKE2B 28f1d505accbbcc04e95c6eeb1b9b36c2ed25fe6ecc73b3b4eb730e79c8c51f57f97cdc7e94076b5ebe8ae7eaeea11665548fdfb13c4bd04bdb5a55ce5073f9f SHA512 9a90054afe0f5c0ed904aa2e13a01b1930883eed4777df90ca8acf4c422a857c981972b7e15159b6b3bbd3797cbc92e3082e87ad4425fdb8e41ff9b0c7cedfaf
MISC metadata.xml 390 BLAKE2B 6be679e40e58985a6ad622fcb85f130bcc6b8039accd14243e6dcba458a0af721eaf9e7928bfe0d29f62477df6e437143865b68a61820b88dfd61a6e760992ea SHA512 3d76be1ae51467569281305138475733f9ce9b89b7d2a41f496c69bebd86e205019d1e75d1de22267d36aa2822ebe8bf94f5722d46ec27a8a79f349e38dad3b4
diff --git a/dev-python/autopage/autopage-0.5.0.ebuild b/dev-python/autopage/autopage-0.5.1.ebuild
index d0b1df26cfa9..586d120bf11c 100644
--- a/dev-python/autopage/autopage-0.5.0.ebuild
+++ b/dev-python/autopage/autopage-0.5.1.ebuild
@@ -3,24 +3,30 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="A library to provide automatic paging for console output"
HOMEPAGE="
+ https://github.com/zaneb/autopage/
https://pypi.org/project/autopage/
- https://github.com/zaneb/autopage/"
+"
SRC_URI="
https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 sparc x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
- test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests unittest