summaryrefslogtreecommitdiff
path: root/dev-python/autocommand
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
commit26f79803004cb53e92cf2f0e889de89979385aa9 (patch)
treed46d17cb971a2dffbe96669e4ad8d341eb5ee3c7 /dev-python/autocommand
parentc5572b13d51970d6603acd131f27991cc1b66a79 (diff)
gentoo auto-resync : 19:11:2022 - 13:00:31
Diffstat (limited to 'dev-python/autocommand')
-rw-r--r--dev-python/autocommand/Manifest2
-rw-r--r--dev-python/autocommand/autocommand-2.2.2.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/autocommand/Manifest b/dev-python/autocommand/Manifest
index 63782deb9bc1..6abdd2a5d939 100644
--- a/dev-python/autocommand/Manifest
+++ b/dev-python/autocommand/Manifest
@@ -1,3 +1,5 @@
DIST autocommand-2.2.1_p20211118.gh.tar.gz 22093 BLAKE2B 186062c0234fc0cc553c5d2a474a5fef46e0de25de8220228715265630fc95ed5f9b64321131322af71fadcc70ef79690652cd555a908b4e8628603a8ee494b2 SHA512 488228c7536f00ff9fbed99677440bfd7228aa64189bbcfb6aad7a92dc698d8283dfbd619ffeaeef883b0e600a90e2a0f56fa79958f144ce673dff53f8d59f89
+DIST autocommand-2.2.2.gh.tar.gz 22188 BLAKE2B 757fd96d0505466e7d3e371e13e931d0dd20d9b02da3e88c2bf85b1b946ef6c67fb14366856fe66c23adab5d635c4bd08d51acc7e55830636cce5aa0a0c265bc SHA512 5ed109db16a0e309ed5107b26db0b70ed8669d73817e82eb5a219650d29f53785aa1f9471b2ac71d21dbffc9f0a13ea0fdf69e63ab534fd84407a1d6741cf5b5
EBUILD autocommand-2.2.1_p20211118.ebuild 702 BLAKE2B d2f27bc8796fad99781c28694abcec3a496f53e7b859b05d7336b45bc739443029f446d4b1e5c22c9c82fbcc83d883b95ca99d95847bffd21ee2b559594fcc15 SHA512 687c1136b7efd25161331c5aede215c0dc18eebc6cd96dcbb9a6e0a8725cb467184b94da1150c10b4300becdcba7c96dc12136a92b0630f3d982c613efcae8ca
+EBUILD autocommand-2.2.2.ebuild 628 BLAKE2B 40afc227cbbc513f76252e29b2ea6e179b7e40047550574f4a48dffae63d48d04f23fc418579ee6c379a66cfc4366670fac6b5bcda3b982f3dec9f044c152b7f SHA512 679dc9bec12c3899d36fe0edeffe83476aa397f1ff3522b7f6c7930461a3544365553bf19092ee81eff74358a7b77d2ff564684b2cad8f7d0abfef7e51077ccc
MISC metadata.xml 400 BLAKE2B 95ed35eafef6d3e0b7535b90e4d3d6f4972ad285decfb2b8a74b118f30899aabf883399ece61272713bcea1a20d0dc56447fab6ac6c11b05c23f542a1a4074b4 SHA512 2d74432fd9281403f4ca70f5b44bdea14a87bb63f70b3b5a53cd4bd5ba1c9b8af64968e351b0605adaeec0bcf9424902c8df821606b54559b6932226d17e6405
diff --git a/dev-python/autocommand/autocommand-2.2.2.ebuild b/dev-python/autocommand/autocommand-2.2.2.ebuild
new file mode 100644
index 000000000000..6cae5f6f33a5
--- /dev/null
+++ b/dev-python/autocommand/autocommand-2.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to create a command-line program from a function"
+HOMEPAGE="
+ https://github.com/Lucretiel/autocommand/
+ https://pypi.org/project/autocommand/
+"
+SRC_URI="
+ https://github.com/Lucretiel/autocommand/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest