summaryrefslogtreecommitdiff
path: root/dev-python/autobahn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/autobahn
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest2
-rw-r--r--dev-python/autobahn/autobahn-20.12.3.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 4bd8a1d7b469..5524939ddc37 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,5 +1,7 @@
DIST autobahn-20.12.2.tar.gz 1269167 BLAKE2B f6ea51682c13690002796f2a45bd11fc2f8497eeee25a1786e942111f43f9dc1f7f806281e4dc37d1ed0aa302fc5c5e47a55d876e010580d7a08eb5ac7534ed0 SHA512 aa6d5e77ba6129931a07cad13f839d5c76267b8126a05ade4ed1c7183ce019faf6656105a853515b543e5ac34ab20d02821b29aa68eb51c385880ad3919d1dcc
+DIST autobahn-20.12.3.tar.gz 1268873 BLAKE2B 44dcaf9d19af89382dfdef9f40a0177486298d451697b973c7a65b44c71c764295afd01ac6333b7a8c5be0348713f38c36884564e148b2941bb42372f07d0e89 SHA512 ad77e476e2eab0039c0a2c98d5851d6237fa7f6a5dfd6b79bd88668dc498bf1b47bb1bcc26ff16e4087cc82aefb0082c8a74afc68b01be48c6140f3aa4ded5b3
DIST autobahn-20.7.1.tar.gz 1260579 BLAKE2B 925d148836348c068d179d4871267bf79c8c42d27cacc6be09cca11396dbd213a5b86344142df886d4ff69d1214a86b49900ca3552bcdb640377cb0d6af7d0f0 SHA512 e2c241194da90ada86a2804683cb063320f75a69b76ddc016349c11614e7f298619c2eeba4fcccb8f8d65d84375681fb339d9f92f94f45f1015f4f12fa0c39b0
EBUILD autobahn-20.12.2.ebuild 3040 BLAKE2B 18f19f325b14341bdb6d272012de8e6582759a24811a74aea84b2ed36c865947b20fe1640c75438d7a3ddde965c35b72d5af3ac66972405e6e228a88ff03c96c SHA512 de18ea1f72d6505a7394ba167c818811eff99c756fee3898cc5400a6a605a56c040c2149edd16dddf3e69d5d549a19a9799afb8c399ed4250e65ecac59dd350a
+EBUILD autobahn-20.12.3.ebuild 3096 BLAKE2B 492bad4b9d9502e0615a7e8f7780934f7bbce7ad298191c7cd76e41dba97adad3c50e4499dabebc8c2541aea5f208a65af831454869daa57da92edf47b4a5bbd SHA512 ff95901737a93cdf3d160771815fe4feafde3898d6d17a7c61b8db4df9859d305789e40324220ac6e9384212361b36f41cfb24743a08653db86b25abb783b2e8
EBUILD autobahn-20.7.1.ebuild 2997 BLAKE2B b16e929b6caed55f547b6221908ff8a937a0fa582a8fd16cee1736efe53de4b82025a116b5a0a66125bf4ba6792db00cb05458d8b6d9e8ead42c123aa984d072 SHA512 742fb89e3df365a06efa09462ba3c1552f1bfe15389d8f7bad08aaebb809ebbbb5f07fb5ec99f10f4911c3e662f05c6b4e14880920f369fdd0da23c10fddd14d
MISC metadata.xml 665 BLAKE2B 11ce0fe43744ff03c46a4e4b6b06733807a4674956dc885a3185bd353f0617841a6f6d1afbbc02c02b7e6718b5c0ccce69907920322e2966c8f7e9d1f63d6485 SHA512 9e154ce907c9868b86a70c4c2f6173e4fa8cc6e1f63380978d4a9c706f00316a9eda488fc39c32c5ea70f31a1a12187629665b590e79f64906ab982bf1401fbb
diff --git a/dev-python/autobahn/autobahn-20.12.3.ebuild b/dev-python/autobahn/autobahn-20.12.3.ebuild
new file mode 100644
index 000000000000..122aefeaa42a
--- /dev/null
+++ b/dev-python/autobahn/autobahn-20.12.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_P=${PN}-$(ver_rs 3 -)
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.org/project/autobahn/
+ https://crossbar.io/autobahn/
+ https://github.com/crossbario/autobahn-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
+IUSE="crypt scram test xbr"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cbor2-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/flatbuffers-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/twisted-20.3.0[${PYTHON_USEDEP}]
+ >=dev-python/txaio-20.4.1[${PYTHON_USEDEP}]
+ >=dev-python/ujson-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-18.1.0[${PYTHON_USEDEP}]
+ )
+ scram? (
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ )
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ if use xbr ; then
+ eerror "***************"
+ eerror "Required xbr dependencies are incomplete in Gentoo."
+ eerror "So this functionality will not yet work"
+ eerror "Please file a bug if this feature is needed"
+ eerror "***************"
+ else
+ # remove xbr components
+ export AUTOBAHN_STRIP_XBR="True"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ echo "Testing all, cryptosign using twisted"
+ export USE_TWISTED=true
+ cd "${BUILD_DIR}"/lib || die
+ "${EPYTHON}" -m twisted.trial autobahn || die
+ unset USE_TWISTED
+ echo "RE-testing cryptosign and component_aio using asyncio"
+ export USE_ASYNCIO=true
+ py.test -v autobahn/wamp/test/test_wamp_cryptosign.py || die
+ py.test -v autobahn/wamp/test/test_wamp_component_aio.py || die
+ unset USE_ASYNCIO
+ rm -r .pytest_cache || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # delete the dropin.cache so we don't have collisions if it exists
+ rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache > /dev/null
+}
+
+pkg_postinst() {
+ python_foreach_impl twisted-regen-cache || die
+}
+
+pkg_postrm() {
+ python_foreach_impl twisted-regen-cache || die
+}