summaryrefslogtreecommitdiff
path: root/dev-python/autobahn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 20:03:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 20:03:41 +0100
commit799073eb168d35819904276f6c912be4ac76166a (patch)
treeb7e4e28f5c6de5e5a382f7578cc5d3249c1e6ea6 /dev-python/autobahn
parenta11ba9ffa8140a9c55c950a6947bc472b489a10a (diff)
gentoo auto-resync : 03:08:2022 - 20:03:40
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest2
-rw-r--r--dev-python/autobahn/autobahn-22.7.1.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 2f82dbc57ab5..a2db988e7cf3 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,5 +1,7 @@
DIST autobahn-22.5.1.tar.gz 435571 BLAKE2B 5e596102b639228d95cea027a0e7187adc4f0910afbd3c5753c0408e070a37b911362eba64c79ce6201000e59381de0941619bef152ca2d784a2c19f1a67a36f SHA512 c27c0f1a782c53df7c152c8043a8e5502f19944e9d5a6ab4a95d02016dfbba70a770f1f4969b75995beed852191bde288d80d1336d56fba1eea190d6590ca642
DIST autobahn-22.6.1.tar.gz 467355 BLAKE2B 54015ee50fa45f23fa589927da232b3ea523efae291b56b44704b66d171075d9459f1c3cf6b96b34fec119deddd2731ebd0695d49345a724bc84b57d7494f332 SHA512 b99f9e4508650fe9484e680b0cd9a0023935445b26ea42fce7565152a5692fc0d1c80f9854b4b3b3004ea17f60d13663477a8710e977211509a14dfad973c635
+DIST autobahn-22.7.1.tar.gz 476789 BLAKE2B 4860a6ec1a2631986dd5d8e94069134e75650eedb67dce18dd4c1e8ad45bd76ca183b4dcbca6ef4474c25f6feb4a1407c9fed4c74f0751e9c0c7fbca2b013406 SHA512 ea2c4d61d3f0f8ef35a31b599bc432781536dccaa316cda474a61003b10df0ef6346615d16228848cc5acb24a4e5f4c50be1fe759daf35b629f636da55688137
EBUILD autobahn-22.5.1-r1.ebuild 3681 BLAKE2B b243c031a8db9bbb87b668ea39f2b3f674d05c054590889d5b7b2f7309b124762e59d278e2eb3e40517344995bd7f8892dcf6fc3bafc5a5cfb80e621ecb32e15 SHA512 c779c1d38e54f125739b178ce06278b98735ecee1dfecdbd98c21f0cb2c1eddb58e6f05a62aca166f1d43c26df5f52ed3bba55c4a027813dfe1aaba3fcbe7ba8
EBUILD autobahn-22.6.1.ebuild 3685 BLAKE2B 38a2c5e862d2d284444ca0e7483914cd7dda97303580fc85c65e2c3f99596baa5208db8480f199681e02be6cebdd2d21f79369d3af9b5a61126a25b936b3a9e2 SHA512 8c729eb36a389c05c262181e6b2e49a43cbe7873172155a60cfd994ef13e9554c185095529bd8edda6cbfddba140686be7aebec7d7825f03eeb1c3f80ff9d262
+EBUILD autobahn-22.7.1.ebuild 3696 BLAKE2B 41c24bc853524f25c4ca94118708cbfc56f733dc0e06113343f2126305f63d6fc00470500db12a965e476a5e97684e077425a29301bc73fc3c2694b4775c2f38 SHA512 e9a61719bed1b14d39626acec28d255a7908a3ac73d99439960916d20d70a48ce7023f429d3b3cc0d38a7076fcff2cc3a62a9dd91f1af755e22f6ae45af5c221
MISC metadata.xml 596 BLAKE2B 07cc4fbcb4c6fde6b1bb49a0a30fa8d2ef7ff4424397e29053a6ac89d87acd9fa7b1897c5381910d53f590192945a89a5b987fcdb9595e42f67f23333010a0ba SHA512 4d4cecf09593ec201711b13de1820e59f007f745b41611471ec737da4d679323787ac06a3a987cede9bf2c8dff71c9dbcb197e6a9c9109cf4d3a34d9247f9962
diff --git a/dev-python/autobahn/autobahn-22.7.1.ebuild b/dev-python/autobahn/autobahn-22.7.1.ebuild
new file mode 100644
index 000000000000..0746e269c44b
--- /dev/null
+++ b/dev-python/autobahn/autobahn-22.7.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+MY_P=${PN}-$(ver_rs 3 -)
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="
+ https://crossbar.io/autobahn/
+ https://github.com/crossbario/autobahn-python/
+ https://pypi.org/project/autobahn/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="test xbr"
+RESTRICT="!test? ( test )"
+
+# The order of deps is based on their appearance in setup.py
+# All extra deps should be included in test and in optfeature
+RDEPEND="
+ >=dev-python/zope-interface-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-20.3.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-20.3.0[${PYTHON_USEDEP}]
+ >=dev-python/txaio-21.2.1[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/hyperlink-21.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${RDEPEND}
+ >=dev-python/wsaccel-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/ujson-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/cbor2-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.16.1[${PYTHON_USEDEP}]
+ >=dev-python/flatbuffers-1.12[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-20.0.1[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-18.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.4[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.14.5[${PYTHON_USEDEP}]
+ >=dev-python/argon2-cffi-20.1.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.4[${PYTHON_USEDEP}]
+
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ if use xbr ; then
+ eerror "***************"
+ eerror "Required xbr dependencies are incomplete in Gentoo."
+ eerror "So this functionality will not yet work"
+ eerror "Please file a bug if this feature is needed"
+ eerror "***************"
+ else
+ # remove xbr components
+ export AUTOBAHN_STRIP_XBR="True"
+ fi
+
+ # avoid useless rust dependency
+ sed -i -e '/cryptography/s:>=3.4.6::' setup.py || die
+
+ # remove twisted plugin cache regen in setup.py
+ # to fix tinderbox sandbox issue
+ sed -e '/import/s:reactor:__importmustfail__:' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ rm -rf autobahn || die
+
+ einfo "Testing all, cryptosign using twisted"
+ local -x USE_TWISTED=true
+ "${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
+ unset USE_TWISTED
+
+ einfo "RE-testing cryptosign and component_aio using asyncio"
+ local -x USE_ASYNCIO=true
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
+ unset USE_ASYNCIO
+
+ rm -f twisted/plugins/dropin.cache || die
+}
+
+pkg_postinst() {
+ optfeature "C-based WebSocket acceleration" "dev-python/wsaccel"
+ optfeature "non-standard WebSocket compression support" "dev-python/snappy"
+ optfeature "accelerated WAMP serialization support" \
+ "dev-python/msgpack dev-python/ujson dev-python/cbor2 dev-python/flatbuffers dev-python/py-ubjson"
+ optfeature "TLS transport encryption" \
+ "dev-python/pyopenssl dev-python/pynacl dev-python/pytrie dev-python/qrcode dev-python/service_identity"
+ optfeature "WAMP-SCRAM authentication" \
+ "dev-python/cffi dev-python/argon2-cffi dev-python/passlib"
+ optfeature "native SIMD acceleration" "dev-python/cffi"
+
+ python_foreach_impl twisted-regen-cache
+}
+
+pkg_postrm() {
+ python_foreach_impl twisted-regen-cache
+}