summaryrefslogtreecommitdiff
path: root/dev-python/authres
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/authres
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/Manifest4
-rw-r--r--dev-python/authres/authres-0.800.ebuild4
-rw-r--r--dev-python/authres/authres-1.1.1.ebuild21
3 files changed, 26 insertions, 3 deletions
diff --git a/dev-python/authres/Manifest b/dev-python/authres/Manifest
index 8b930695c613..df7db080e6a2 100644
--- a/dev-python/authres/Manifest
+++ b/dev-python/authres/Manifest
@@ -1,3 +1,5 @@
DIST authres-0.800.tar.gz 19863 BLAKE2B 01f9264a78ef5a3ee9fa1db17dd4fc5d1e849a5f297f610ab0bda09f4900bca15e63d71c2312e12b1e6173213d3eef938dae996c7bcc599de496b6c77001de87 SHA512 d9e73309064e396c51ed55394ce505c21869d267922df55b6723cb6b2409282c7827d35d381877b5f08e037042e015d59246603d51219c829df7b81011499fe7
-EBUILD authres-0.800.ebuild 608 BLAKE2B 8fb7945a3289eb94d5eba23d3063e6ca6831922c16fd4715726cd9d97f6564e7b20a9fa1640309ba1b825cbc07e5c206b07a837c657b180d9d45841f5ab97343 SHA512 71d1f8417e6cf37781ed32e16154f7d8ad8f225d71de3b14b91a27b85707e717a14bcf1b6e0c599e28b82c192374c29cfbc9f41fc6470dfff94a68a2e702e40f
+DIST authres-1.1.1.tar.gz 23180 BLAKE2B 8ca2e0a0e93da50188d721be1fd60604ec2fdedb117df39c6e74d454d48d008a1627b45acbc18df3bc3c386794d7ac91e31ccca131c9e6e04f6bb34417f64c50 SHA512 61e73e85e524279d5db37375fbe7b1fcf65a24280ef61124a94e4236ce477c225637690e9d424f5ee3fef8b9cd3d26c6d512dfa3c1c8491fa4f4bf266f88ac80
+EBUILD authres-0.800.ebuild 601 BLAKE2B 574ff453a149edfe7099d477d40b20dcad735e26d1ec767d0a50f494f58524533a066f6e88fef1809b57b371a46683599a80bc05913b9aa4e620be3c2e3d347d SHA512 cf28623b12c682c0c36ebab3fd77febce9b16e5d57cee176207f79239d6d07a775217e31e61474444601defb4b1a39ba49a6a34ed86069d3015f697b4d92ec5f
+EBUILD authres-1.1.1.ebuild 564 BLAKE2B e40a7d0c459ec2ca1e46fd8b6156c7a73868983ac2bebab8c7b9f2323edcd4ef948bf9ddd7f5c2d040c29a2ada01a235c831b1c2e281dd9e737845feae5c88c6 SHA512 e74ef1dc59250a1264161eaa77cfb92d7447974b1508cea2465fd8ae7bfd0baae93d84d2d38c9a9c163075ce3e7ce792c406037be30b27c36daecc640192e709
MISC metadata.xml 659 BLAKE2B 96a0bbbd3a801f527d61237bf4de6b1140cdbb316571efbf4934a0398b6f171ea04bb9c80eca90809ba00eb4b8a2bf9806442752d58e5fc2b43e5c7438425762 SHA512 166514ed6b7ff4e3a3acb703da72e72865ef51b067595375f36bc45541483629582828980befba2711d7b7555f571b91c777162a0996ce57f735a0934c4dfb9d
diff --git a/dev-python/authres/authres-0.800.ebuild b/dev-python/authres/authres-0.800.ebuild
index 1e4d080bd77a..a151b5687444 100644
--- a/dev-python/authres/authres-0.800.ebuild
+++ b/dev-python/authres/authres-0.800.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
inherit distutils-r1
diff --git a/dev-python/authres/authres-1.1.1.ebuild b/dev-python/authres/authres-1.1.1.ebuild
new file mode 100644
index 000000000000..194c7205ebfc
--- /dev/null
+++ b/dev-python/authres/authres-1.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Authentication-Results Headers generation and parsing"
+HOMEPAGE="https://launchpad.net/authentication-results-python https://pypi.org/project/authres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" -m doctest -v authres/tests ||
+ die "Tests fail with ${EPYTHON}"
+}