summaryrefslogtreecommitdiff
path: root/dev-python/authheaders
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/authheaders
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/authheaders')
-rw-r--r--dev-python/authheaders/Manifest3
-rw-r--r--dev-python/authheaders/authheaders-0.11.0.ebuild25
-rw-r--r--dev-python/authheaders/metadata.xml14
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/authheaders/Manifest b/dev-python/authheaders/Manifest
new file mode 100644
index 000000000000..bd15ab611e6b
--- /dev/null
+++ b/dev-python/authheaders/Manifest
@@ -0,0 +1,3 @@
+DIST authheaders-0.11.0.tar.gz 88501 BLAKE2B a4ef01d206c470c4d97443af2b770d301de59aaed709ab72f439c43e0fa11e20a4a0b7f4122cf3c3212781750a1505af7a8143be9277a7989819948c1c18274a SHA512 7d0d8750eb606f3e52e85159e6b5da2fe377816e7572ee01b6bc90dffa996717c0f2837e52b170ecbd97b7617461a0b96d0736084590673a516e7d3ae7e8f999
+EBUILD authheaders-0.11.0.ebuild 734 BLAKE2B f4700ad87ad5f73ff82b3fed1691f9307880dc0e87ad33db8230c8d9d22529cbc900180fa8c622378672f5f49e188ce10eed07cd47750406825fe8be5cb8138c SHA512 89dd49322ef0febd04964388d63cb90ac274e5019fc33ff3810e8978226e567e827a88a90c0996a0580e4516d1fb0352d78e178d24f53fa318cb239fc7e19468
+MISC metadata.xml 462 BLAKE2B 136929c00b3dc09352eafe4819eb1aa20ca5e6f9742036cc9bbf2dcefaf9e2c9173d39450ac27d5900573e78b3bc5e95de90e06b319ab2ccffb352d96aaf48af SHA512 a748fce55630560f5ad5315361c1cb23db3b74d416fc24bfd61c0aea6f722f363db521efd898f9495838c618ae109f3490fb047d8eba515304304ce7468c2a76
diff --git a/dev-python/authheaders/authheaders-0.11.0.ebuild b/dev-python/authheaders/authheaders-0.11.0.ebuild
new file mode 100644
index 000000000000..a3320424a3b9
--- /dev/null
+++ b/dev-python/authheaders/authheaders-0.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A library wrapping email authentication header verification and generation."
+HOMEPAGE="https://github.com/ValiMail/authentication-headers"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/dkimpy[${PYTHON_USEDEP}]
+ >=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]"
+BDEPEND=""
diff --git a/dev-python/authheaders/metadata.xml b/dev-python/authheaders/metadata.xml
new file mode 100644
index 000000000000..1fc8047f9176
--- /dev/null
+++ b/dev-python/authheaders/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a Python library for the generation of email authentication headers.
+ </longdescription>
+</pkgmetadata>