summaryrefslogtreecommitdiff
path: root/dev-python/audioread
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/audioread
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/audioread')
-rw-r--r--dev-python/audioread/Manifest6
-rw-r--r--dev-python/audioread/audioread-1.0.1-r1.ebuild31
-rw-r--r--dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch30
-rw-r--r--dev-python/audioread/metadata.xml15
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/audioread/Manifest b/dev-python/audioread/Manifest
new file mode 100644
index 000000000000..40e4cd20ee55
--- /dev/null
+++ b/dev-python/audioread/Manifest
@@ -0,0 +1,6 @@
+AUX 0001-Use-the-print-function-instead-of-the-print-keyword.patch 981 SHA256 0c887e92b7a0d940833cf0c953929b18733222c85b2cf6b8a4c04cf6d04ce24d SHA512 6dbd099bf334af6674b24b87f17d7f97d00978c5817d852608b5e835efaa988897c9713e55f04ab9e567595686459a4e5e840aba61df6bfd80d9b80d18622c8a WHIRLPOOL b7eddbc10a5503b0359a5aedb333532448fbc4668a25dfd313b69725633f079e876cb609056e8228c5f8355f65b63ea0a0cf46dd71aa4f5773f656d02dc8327d
+DIST audioread-1.0.1.tar.gz 13004 SHA256 19d1a8c55b00875235a198cb9119c2163394000ebbb0f05a074a356f71a96b04 SHA512 18e9e696785fe2f1b1d6ad7fe64e2878bf490d72aef7500998bb48b0733b382cf0b171d26c5b1465947de1d5f6ded25e2b57947402c31a440e8f346722fdc533 WHIRLPOOL 9489c01f54135677a01d2511d80150bd5f134b8b08ee20b55f78f708a788e604c282f43ea5ffbc669f2a00b3c2ae14f9062fe6752b21e14d1c50f4d36c3e2c6b
+EBUILD audioread-1.0.1-r1.ebuild 775 SHA256 93c77691a87bf0e6d3f45d85c5d6dd63f0718bc30819eb84f9b64baf2c4c60b9 SHA512 dd31fef40c0f209be59109cc09633555d7c6540de2221b8aa7a9a4fffde32814b98f0e8bba5b666c1e1fcf9bdac6edaf7fd34e893f80dedafa46f1552545e4e6 WHIRLPOOL 437577519dc514f003a133832d5fb120a9f09e82b3f9a88e84d08ddb48e740b293e3265dfbf7dfd955c95c1faae8ed8ce3f51b22b098221aec6013da2b7f307d
+MISC ChangeLog 2878 SHA256 d0cd922a5f0c7920b69a391cddae363ac6f10f0ea0ec102c59a9ae584ca49f10 SHA512 e224421d509134b9fa58a035a2c383a6f3d78977e3b11a67c951988804d0efd2786cc27e2e4a78f73dd81221958aa7b4676cc861303ebd05722ade4ee54acf12 WHIRLPOOL 977e6a467dd7f38e2241d8ee99a2bce9847f9d3d67b73615157e5f08b71b00542791de4a13595feb9736dc4984a69b080b9396f7aa23dc8cb218a23fd85592cf
+MISC ChangeLog-2015 1614 SHA256 9cfefc955b30ad65cc30de317dfbc630a3655c0178eb739b3743bb459dc83e77 SHA512 e8e8bb0965d488664724555580a50f5cef6d2465492ecd99401260688fefdd7fab02c88d4e5c2bf1989591e6346be44ef2a8bb3b2eff4f0b1663187e87bbed24 WHIRLPOOL c202b31b60ce4a10fc6b90c1c2381b995ed8b4976f616013c5f530d55b17f189a9d60010867d01b9312c82ce0c60ef176e1c45416faeb0b6d9d682f9af8e4bd2
+MISC metadata.xml 557 SHA256 b28220068a25df3879fb622399be4db6031abec10fe6441a2ed90a4a2b440395 SHA512 1c5f505d0512c0eabe2e1fbedcf62421fca6d6e12a479aec0ac71384377e032e2697858b06efc9196a35e96b2f795682730fbed7153c610b1057fda376d00460 WHIRLPOOL d07c2d9ea3efee485e5b623b18f2566b03cd6cb25bc659c9a4e73fb33de099c547c05e07fd6ff3f5e0e6710f20f465f90d7dfcf994f6df3daf240c7b48c3d259
diff --git a/dev-python/audioread/audioread-1.0.1-r1.ebuild b/dev-python/audioread/audioread-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..5c8a480f88b7
--- /dev/null
+++ b/dev-python/audioread/audioread-1.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decoding audio files using whichever backend is available"
+HOMEPAGE="https://pypi.python.org/pypi/audioread"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
+ )
+
+pkg_postinst() {
+ einfo "You might need to enable additional USE flags in backends to"
+ einfo "decode some types of audio files. Priority of backends:"
+ einfo " * mad"
+ einfo " * ffmpeg"
+}
diff --git a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
new file mode 100644
index 000000000000..8feb9d0ca9b6
--- /dev/null
+++ b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
@@ -0,0 +1,30 @@
+From 3f86133d37d5cc5c8712730de67c23b0d33ce082 Mon Sep 17 00:00:00 2001
+From: Simon Chopin <chopin.simon@gmail.com>
+Date: Tue, 14 May 2013 12:46:50 +0200
+Subject: [PATCH] Use the print() function instead of the print keyword
+
+Python3 doesn't have the `print foo` statement.
+---
+ audioread/gstdec.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/audioread/gstdec.py b/audioread/gstdec.py
+index 78285db..fa8078f 100644
+--- a/audioread/gstdec.py
++++ b/audioread/gstdec.py
+@@ -366,8 +366,8 @@ if __name__ == '__main__':
+ for path in sys.argv[1:]:
+ path = os.path.abspath(os.path.expanduser(path))
+ with GstAudioFile(path) as f:
+- print f.channels
+- print f.samplerate
+- print f.duration
++ print(f.channels)
++ print(f.samplerate)
++ print(f.duration)
+ for s in f:
+- print len(s), ord(s[0])
++ print(len(s), ord(s[0]))
+--
+1.8.1.5
+
diff --git a/dev-python/audioread/metadata.xml b/dev-python/audioread/metadata.xml
new file mode 100644
index 000000000000..805c723460fd
--- /dev/null
+++ b/dev-python/audioread/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+Decode audio files using whichever backend is available. The library currently supports:
+ * Gstreamer via gst-python.
+ * MAD via the pymad bindings.
+ * FFmpeg via its command-line interface.
+ * The standard library wave and aifc modules (for WAV and AIFF files).
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">audioread</remote-id>
+ </upstream>
+</pkgmetadata>