summaryrefslogtreecommitdiff
path: root/dev-python/audioread/audioread-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
commitb392cbf078526e18db5d54ec37f9580be480fd48 (patch)
treef2f8f60717bb0fbe3df7452c2e0b1e0c192341d1 /dev-python/audioread/audioread-3.0.0.ebuild
parentcd40bc9ab405aca4e72f869db79d9d1ff77d8313 (diff)
gentoo auto-resync : 13:08:2022 - 14:24:01
Diffstat (limited to 'dev-python/audioread/audioread-3.0.0.ebuild')
-rw-r--r--dev-python/audioread/audioread-3.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/audioread/audioread-3.0.0.ebuild b/dev-python/audioread/audioread-3.0.0.ebuild
new file mode 100644
index 000000000000..d17c0e0ef106
--- /dev/null
+++ b/dev-python/audioread/audioread-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper for audio file decoding using FFmpeg or GStreamer"
+HOMEPAGE="
+ https://github.com/beetbox/audioread/
+ https://pypi.org/project/audioread/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gstreamer mad"
+
+RDEPEND="
+ ffmpeg? (
+ media-video/ffmpeg
+ )
+ gstreamer? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ mad? (
+ dev-python/pymad[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pymad[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest