summaryrefslogtreecommitdiff
path: root/dev-python/attrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /dev-python/attrs
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest3
-rw-r--r--dev-python/attrs/attrs-23.2.0.ebuild8
-rw-r--r--dev-python/attrs/files/attrs-23.2.0-py313.patch93
3 files changed, 101 insertions, 3 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 2e96d003bbf6..4d31b5d90a6d 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,4 +1,5 @@
+AUX attrs-23.2.0-py313.patch 2882 BLAKE2B 81a30df9d7a438570256967df413347dafa3bee4611eef2d1e5d37c4d2a9c100b8464440ffe1dfe0d204f0e201e427201b6011da89283d63acfb554a2b309443 SHA512 e7da6587b59c9e213bf3f58324694780db4e583c129f42b6b4b2b475b4020ba5620aec96da2928ddb8054c225f49e0b1f46f996af2a6e0d78b4a47e4669945b2
AUX attrs-23.2.0-pytest-8.patch 1459 BLAKE2B 3388ed0e6022b1df0634031155c93abec6cf67a46a912c6a8415356337deeae1264566b65858e88b901d1cca55a7fa4a38c6ad7ad099596396d8936337fd2c62 SHA512 10bbd4a8863fcda3be30e99137283d5112189900403018f5780511d0995bf120132bd248fdc42436912be28b09a69bda9974c97b3859c281167442cc38f32705
DIST attrs-23.2.0.tar.gz 780820 BLAKE2B a06f4f17a81fc173c37661bcf518367a1cdc9a333d2783bd2cd1ac5f0a72bd20ec1afdd964e10255624bcfa027e3a152375cd21472c177428d29bd06b29984a1 SHA512 d8b178072a028b95d8424cd3ce0c8b4e6da8558fbcbcaaef91fbd03cf51e6190aa248aa0bff853e6f7c9595bbd5a8eef9d6f68ae2830cc1cc6d826ab0dda2378
-EBUILD attrs-23.2.0.ebuild 1038 BLAKE2B 888102b3fa59978ec11fc65544086e4092640b73dcd8328b45d3da09f7e00ee8080bf51fe1302c2dfd45b197c204af3bd12d2d0476e34d370985bf77653b01b3 SHA512 c8a3218b2262c94a4a3a78226befb373c4e33b6905b85d08afa89c80ebfc0a652e4831ae16ee915b2011c4695e013331ba2cb7769e93f94b55be11615e82ae03
+EBUILD attrs-23.2.0.ebuild 1176 BLAKE2B f11703968cda2c53415657895ad1402734b891ce57f3fcb3df92a604e306fd501cd3697d99b9acaf06a18594da786903c5d6d459d2c6401e1794f44ee5c9047a SHA512 5fc840baebf41386e5b47d2e3b000fd061d8f26d3ca104c68769c3b9232b3f7aa0847318532e71ae1d2c5093c091e949ea6a6911e2eedf3862c87ab9b4ce6663
MISC metadata.xml 586 BLAKE2B d54794200f471af72d635c0cda12d773ff78f1083a9a6d2b0785b203789b2432b10ee7332f5abcd8f8dda952e10e4f981d51bbbfc4a6d461524570b3c5168f18 SHA512 b1161bb1ad04faea3ca915847d739287bc8bf9695608e49344ac6c9c4c16bb6818313a79b036df0cddde1da2d84740cf2d0b7d0c23d6cf3f22315046a3732f78
diff --git a/dev-python/attrs/attrs-23.2.0.ebuild b/dev-python/attrs/attrs-23.2.0.ebuild
index 5c18c763b029..6e858669ffbc 100644
--- a/dev-python/attrs/attrs-23.2.0.ebuild
+++ b/dev-python/attrs/attrs-23.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -28,7 +28,9 @@ BDEPEND="
dev-python/cloudpickle[${PYTHON_USEDEP}]
' python3_{10..12})
dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ ' python3_{10..12} pypy3)
)
"
@@ -37,4 +39,6 @@ distutils_enable_tests pytest
PATCHES=(
# https://github.com/python-attrs/attrs/pull/1249
"${FILESDIR}/${P}-pytest-8.patch"
+ # https://github.com/python-attrs/attrs/pull/1255
+ "${FILESDIR}/${P}-py313.patch"
)
diff --git a/dev-python/attrs/files/attrs-23.2.0-py313.patch b/dev-python/attrs/files/attrs-23.2.0-py313.patch
new file mode 100644
index 000000000000..f7ea8f5e659f
--- /dev/null
+++ b/dev-python/attrs/files/attrs-23.2.0-py313.patch
@@ -0,0 +1,93 @@
+From f9ff9135b472c78a7333d6272c62b92217897464 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Lum=C3=ADr=20=27Frenzy=27=20Balhar?=
+ <frenzy.madness@gmail.com>
+Date: Thu, 7 Mar 2024 10:23:46 +0100
+Subject: [PATCH] Fix test_ne in test_cmp.py for Python 3.13 (#1255)
+
+* Fix test_ne in test_cmp.py for Python 3.13
+
+Compiler in Python 3.13+ strips indents from docstrings
+so they need to be compared without it for new Pythons.
+
+Fixes: https://github.com/python-attrs/attrs/issues/1228
+
+* [pre-commit.ci] auto fixes from pre-commit.com hooks
+
+for more information, see https://pre-commit.ci
+
+---------
+
+Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>
+---
+ src/attr/_compat.py | 1 +
+ tests/test_cmp.py | 11 +++++++----
+ 2 files changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/src/attr/_compat.py b/src/attr/_compat.py
+index 46b05ca..9010047 100644
+--- a/src/attr/_compat.py
++++ b/src/attr/_compat.py
+@@ -14,6 +14,7 @@ PY_3_8_PLUS = sys.version_info[:2] >= (3, 8)
+ PY_3_9_PLUS = sys.version_info[:2] >= (3, 9)
+ PY310 = sys.version_info[:2] >= (3, 10)
+ PY_3_12_PLUS = sys.version_info[:2] >= (3, 12)
++PY_3_13_PLUS = sys.version_info[:2] >= (3, 13)
+
+
+ if sys.version_info < (3, 8):
+diff --git a/tests/test_cmp.py b/tests/test_cmp.py
+index 07bfc52..b84b66f 100644
+--- a/tests/test_cmp.py
++++ b/tests/test_cmp.py
+@@ -4,10 +4,10 @@
+ Tests for methods from `attrib._cmp`.
+ """
+
+-
+ import pytest
+
+ from attr._cmp import cmp_using
++from attr._compat import PY_3_13_PLUS
+
+
+ # Test parameters.
+@@ -54,6 +54,9 @@ order_ids = [c[0].__name__ for c in order_data]
+ cmp_data = eq_data + order_data
+ cmp_ids = eq_ids + order_ids
+
++# Compiler strips indents from docstrings in Python 3.13+
++indent = "" if PY_3_13_PLUS else " " * 8
++
+
+ class TestEqOrder:
+ """
+@@ -325,7 +328,7 @@ class TestDundersUnnamedClass:
+ method = self.cls.__ne__
+ assert method.__doc__.strip() == (
+ "Check equality and either forward a NotImplemented or\n"
+- " return the result negated."
++ f"{indent}return the result negated."
+ )
+ assert method.__name__ == "__ne__"
+
+@@ -393,7 +396,7 @@ class TestDundersPartialOrdering:
+ method = self.cls.__ne__
+ assert method.__doc__.strip() == (
+ "Check equality and either forward a NotImplemented or\n"
+- " return the result negated."
++ f"{indent}return the result negated."
+ )
+ assert method.__name__ == "__ne__"
+
+@@ -465,7 +468,7 @@ class TestDundersFullOrdering:
+ method = self.cls.__ne__
+ assert method.__doc__.strip() == (
+ "Check equality and either forward a NotImplemented or\n"
+- " return the result negated."
++ f"{indent}return the result negated."
+ )
+ assert method.__name__ == "__ne__"
+
+--
+2.45.0
+