summaryrefslogtreecommitdiff
path: root/dev-python/attrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-01 20:14:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-01 20:14:16 +0100
commit113536ff120085dc1a7b12260095732209a389f8 (patch)
tree52a6c3df9c740efb71c815094e03456be4558c51 /dev-python/attrs
parent5b1915ddf98b64efdd976ca4d8fce232faf7a247 (diff)
gentoo auto-resync : 01:04:2024 - 20:14:15
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest3
-rw-r--r--dev-python/attrs/attrs-23.2.0.ebuild5
-rw-r--r--dev-python/attrs/files/attrs-23.2.0-pytest-8.patch44
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 5c67d1a79db5..2e96d003bbf6 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,3 +1,4 @@
+AUX attrs-23.2.0-pytest-8.patch 1459 BLAKE2B 3388ed0e6022b1df0634031155c93abec6cf67a46a912c6a8415356337deeae1264566b65858e88b901d1cca55a7fa4a38c6ad7ad099596396d8936337fd2c62 SHA512 10bbd4a8863fcda3be30e99137283d5112189900403018f5780511d0995bf120132bd248fdc42436912be28b09a69bda9974c97b3859c281167442cc38f32705
DIST attrs-23.2.0.tar.gz 780820 BLAKE2B a06f4f17a81fc173c37661bcf518367a1cdc9a333d2783bd2cd1ac5f0a72bd20ec1afdd964e10255624bcfa027e3a152375cd21472c177428d29bd06b29984a1 SHA512 d8b178072a028b95d8424cd3ce0c8b4e6da8558fbcbcaaef91fbd03cf51e6190aa248aa0bff853e6f7c9595bbd5a8eef9d6f68ae2830cc1cc6d826ab0dda2378
-EBUILD attrs-23.2.0.ebuild 939 BLAKE2B 1b4ae5a08a7d2fd55dfc1db2bd2052b2d8f56e2183d77e4eafe7e92835d6b20e9d47d3d46aca835177703abd66b961e93822d7bc169e6a22d468a5f0be67a87d SHA512 04ee96b6339aa1aaea13900bccf21d2bab15374178cbab0b7d40db90ed0153ba64c315c1c52232f6df27bc3eb646a989e9eb3a6e5f31e7d09b167e7b2a113d02
+EBUILD attrs-23.2.0.ebuild 1038 BLAKE2B 888102b3fa59978ec11fc65544086e4092640b73dcd8328b45d3da09f7e00ee8080bf51fe1302c2dfd45b197c204af3bd12d2d0476e34d370985bf77653b01b3 SHA512 c8a3218b2262c94a4a3a78226befb373c4e33b6905b85d08afa89c80ebfc0a652e4831ae16ee915b2011c4695e013331ba2cb7769e93f94b55be11615e82ae03
MISC metadata.xml 586 BLAKE2B d54794200f471af72d635c0cda12d773ff78f1083a9a6d2b0785b203789b2432b10ee7332f5abcd8f8dda952e10e4f981d51bbbfc4a6d461524570b3c5168f18 SHA512 b1161bb1ad04faea3ca915847d739287bc8bf9695608e49344ac6c9c4c16bb6818313a79b036df0cddde1da2d84740cf2d0b7d0c23d6cf3f22315046a3732f78
diff --git a/dev-python/attrs/attrs-23.2.0.ebuild b/dev-python/attrs/attrs-23.2.0.ebuild
index a0aa7acc3ff7..5c18c763b029 100644
--- a/dev-python/attrs/attrs-23.2.0.ebuild
+++ b/dev-python/attrs/attrs-23.2.0.ebuild
@@ -33,3 +33,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/python-attrs/attrs/pull/1249
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
diff --git a/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch b/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch
new file mode 100644
index 000000000000..68e4c86c1315
--- /dev/null
+++ b/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch
@@ -0,0 +1,44 @@
+From b9084fab02c009a593b604562a69f36a5915c8e5 Mon Sep 17 00:00:00 2001
+From: Denis Laxalde <denis@laxalde.org>
+Date: Sat, 2 Mar 2024 07:40:36 +0100
+Subject: [PATCH] Remove pytest.deprecated_call() in TestAssoc::test_unknown
+ (#1249)
+
+assoc() no longer raises a deprecation warning since commit
+22ae8473fb88d6e585b05c709e81e1a46398a649 but the 'with
+pytest.deprecated_call():' in that test was not removed then (in
+contrast with other test cases).
+
+Maybe this got unnoticed due to a pytest bug?
+In any case, using pytest 8+ (and keeping deprecated_call()) shows that
+no warning is raised and the test fails.
+
+Removing the upper bound on pytest in dev dependencies as tests now
+pass with pytest 8.0.
+
+Fix #1233.
+
+Co-authored-by: Hynek Schlawack <hs@ox.cx>
+---
+ pyproject.toml | 3 +--
+ tests/test_funcs.py | 4 +---
+ 2 files changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/tests/test_funcs.py b/tests/test_funcs.py
+index 044aaab..398ba35 100644
+--- a/tests/test_funcs.py
++++ b/tests/test_funcs.py
+@@ -600,9 +600,7 @@ class TestAssoc:
+ AttrsAttributeNotFoundError.
+ """
+ # No generated class will have a four letter attribute.
+- with pytest.raises(
+- AttrsAttributeNotFoundError
+- ) as e, pytest.deprecated_call():
++ with pytest.raises(AttrsAttributeNotFoundError) as e:
+ assoc(C(), aaaa=2)
+
+ assert (f"aaaa is not an attrs attribute on {C!r}.",) == e.value.args
+--
+2.44.0
+