summaryrefslogtreecommitdiff
path: root/dev-python/attrs/attrs-23.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 23:51:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 23:51:54 +0000
commitbf90f82fef4fc737c88b58cd31428ad4355c17fa (patch)
treefc72ac72a2f48adcbc9b83d64185c7747727566a /dev-python/attrs/attrs-23.2.0.ebuild
parent027dc9b3977cd14e0c7ae52e7bf9370c3919afa1 (diff)
gentoo auto-resync : 31:12:2023 - 23:51:53
Diffstat (limited to 'dev-python/attrs/attrs-23.2.0.ebuild')
-rw-r--r--dev-python/attrs/attrs-23.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/attrs/attrs-23.2.0.ebuild b/dev-python/attrs/attrs-23.2.0.ebuild
new file mode 100644
index 000000000000..029d6ff9af6c
--- /dev/null
+++ b/dev-python/attrs/attrs-23.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-23.2.0[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ $(python_gen_cond_dep '
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ ' python3_{10..12})
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest