summaryrefslogtreecommitdiff
path: root/dev-python/atpublic/atpublic-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/atpublic/atpublic-1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/atpublic/atpublic-1.0.ebuild')
-rw-r--r--dev-python/atpublic/atpublic-1.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/atpublic/atpublic-1.0.ebuild b/dev-python/atpublic/atpublic-1.0.ebuild
new file mode 100644
index 000000000000..10513575bb33
--- /dev/null
+++ b/dev-python/atpublic/atpublic-1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A decorator and function to polulate a module's __all__ and the module globals."
+HOMEPAGE="https://gitlab.com/warsaw/public"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"