summaryrefslogtreecommitdiff
path: root/dev-python/atomicwrites
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/atomicwrites
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/atomicwrites')
-rw-r--r--dev-python/atomicwrites/Manifest4
-rw-r--r--dev-python/atomicwrites/atomicwrites-1.1.5-r2.ebuild25
-rw-r--r--dev-python/atomicwrites/atomicwrites-1.1.5-r3.ebuild41
-rw-r--r--dev-python/atomicwrites/metadata.xml12
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/atomicwrites/Manifest b/dev-python/atomicwrites/Manifest
new file mode 100644
index 000000000000..a56e12e38455
--- /dev/null
+++ b/dev-python/atomicwrites/Manifest
@@ -0,0 +1,4 @@
+DIST atomicwrites-1.1.5.tar.gz 18951 BLAKE2B b0932995aae3ca23c11aace182429f4888819ea542a12b59d5b7ed4621c4759285d0cba306437bd1ce35b1ba32eac8ae6afc6548f2bae61870dbf03927c4fe75 SHA512 4de8ab93dcb226c55e8ae1b0ef883c2e1eeae50ac6596afe036ca51dbf6b094c13dbf2d792972312d4c53551886aaa2713aac54bfab42b85abef4d1146e039ac
+EBUILD atomicwrites-1.1.5-r2.ebuild 578 BLAKE2B ad9188acc6f21a3352510d2efae465d010e763f21f45d6604979b4a48da0e77817746037f8472bc86bdd034163e0c75da40a56784eb0e979e856b5dc86d8eeb0 SHA512 1af57e581631a2cda8f7ee9de709bbd2abb1475d5f25331d9fa2683e5b75892f897e68f092f96b5ffe522a5d2b1966aca0a81a37fe80c38f08b9599d63d2b715
+EBUILD atomicwrites-1.1.5-r3.ebuild 915 BLAKE2B 92a50d27d0c31ee35b3315706f77c46e87ac5253989b6cb6911be3de7c6c354ac1d941b58de4ee8efa4f01d16726dc63738344f2cd6eaa405e5adc9c5930bf5a SHA512 3c6603a11de4d3420d40f45fa9fb3a2dd63afd647b9ea37ae9374df148d075b4e0032cfca31baed6daf4c9737251f1c7bbdf7ae4f786e75cbb669ee719971798
+MISC metadata.xml 438 BLAKE2B c2a138ede668039b703fdc3e2ca8e1a7a07546e01540fdc502d79a48a8ddfae8dc7a79ed371373d95054731fcb25af67daf75ef5a1c08fafe9976f7a2c30525d SHA512 f38332e752b8bb660d8d8291b897fc96865a134108198e01df2dc4365c0c6e87c6039a907da38080a4d07d7c57750f8a32c6d6c3653b57f5aa193ca5b5b53449
diff --git a/dev-python/atomicwrites/atomicwrites-1.1.5-r2.ebuild b/dev-python/atomicwrites/atomicwrites-1.1.5-r2.ebuild
new file mode 100644
index 000000000000..e8df8bc048ad
--- /dev/null
+++ b/dev-python/atomicwrites/atomicwrites-1.1.5-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Atomic file writes"
+HOMEPAGE="https://github.com/untitaker/python-atomicwrites"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/atomicwrites/atomicwrites-1.1.5-r3.ebuild b/dev-python/atomicwrites/atomicwrites-1.1.5-r3.ebuild
new file mode 100644
index 000000000000..75fd01fc4968
--- /dev/null
+++ b/dev-python/atomicwrites/atomicwrites-1.1.5-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Atomic file writes"
+HOMEPAGE="https://github.com/untitaker/python-atomicwrites"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/atomicwrites/metadata.xml b/dev-python/atomicwrites/metadata.xml
new file mode 100644
index 000000000000..26b05060cf14
--- /dev/null
+++ b/dev-python/atomicwrites/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>amynka@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">untitaker/python-atomicwrites</remote-id>
+ <remote-id type="pypi">atomicwrites</remote-id>
+ <bugs-to>https://github.com/untitaker/python-atomicwrites/issues</bugs-to>
+ </upstream>
+</pkgmetadata>