summaryrefslogtreecommitdiff
path: root/dev-python/asyncstdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/asyncstdlib
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.2-r1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index 2bf80b5ef27c..859e7b777479 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1,3 +1,4 @@
DIST asyncstdlib-3.10.2.gh.tar.gz 45697 BLAKE2B 8f9bbee8d2a4e9f6a60a5088ef00940f22c2aec79557070d1b13d8d7256179bddaf1130ace0393e95e06e077824dd862e27a6c5d644ae52dab2d80989bb08027 SHA512 be5a8cbb521b8082ad9898907bce1a888443eafb24e2030f9dfbb2dff293646376ad44ebbc53d12e539ad70af935d833f2f114e383171388b9d724f274eb8421
+EBUILD asyncstdlib-3.10.2-r1.ebuild 610 BLAKE2B 7e0b105ec6009fd2d0f56ce033bbefc84f3e0689b70ad66171688070318638baeca6bea4e7ed3e45c2b1e0824813dd587ef726dbdbffc87a98b90cc9a129eca1 SHA512 230e2b354e114d42b630cfe7cb955418e4b0eb76aa805bb19ab209e5898a27bcf30c3db1f11b7ea9bcf787e5febf159f1a9fc7fa5d1e8664cb68624338d673d6
EBUILD asyncstdlib-3.10.2.ebuild 521 BLAKE2B 29f1d54b54ab23d5c364106db4c0bedadbea9a9c5336fc4d799fd1ecd8f55a59a940e832e5c4767290c5e320317d73e788dffee6bbe895bbfb9dec5574dd8a28 SHA512 673c9e2bab7be93ee4d35b2cfc1adbc2275bf9a1b5457f9a68d5df163328daac286887b2af0280e429cdf2a0f67c3475a694c1de3d9c5b526122dd50f322e4cc
MISC metadata.xml 359 BLAKE2B 10bdbf5adba9cefa912d8e1f195f20d4040bc2e8e3efb3fdc6efcb8272bb58160c6d772de3fe9ad9c4cb43e2817139319ffece082c3c043f1d97cb36ed8ac7a8 SHA512 e56f712f7446a3e68137a945a1ab212f6254740ce2f962fc7ab0061f41cb0d314809ad4fe3317fd10d8ebb594fb20d690d06b0a73636b13b5fdb5184cde2e306
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.2-r1.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.2-r1.ebuild
new file mode 100644
index 000000000000..64b97b2b04eb
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '2,3s:flit:&_core:' pyproject.toml || die
+ distutils-r1_src_prepare
+}