summaryrefslogtreecommitdiff
path: root/dev-python/asyncstdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
commit996a2bda06cb164877d5d952774a6db1b271c2f3 (patch)
tree31930352b48fc7622d658ae37658c57ad9511ef6 /dev-python/asyncstdlib
parent67e5603b2844a6657dd0438fa26626b013e5567f (diff)
gentoo auto-resync : 25:06:2024 - 00:12:20
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/Manifest2
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index 23c0c2c3ba9f..b8a371a9e64d 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1,3 +1,5 @@
DIST asyncstdlib-3.12.3.tar.gz 47118 BLAKE2B 83967dc89c0a5fab13ff5f3cebec739644ba16479bf661447c179b491897be0a5933f6ae724f942643d349cef8eaff66cf621c565459b1b8774e93bc51e472ee SHA512 239f0741a694f58e359422bce1e54f6f7e3b1522f10ed4cfd137f4cd8c9861156744d7efa98ab155dd0aa489dbdc452c095d60b77922c6b53177708a65a26d86
+DIST asyncstdlib-3.12.4.tar.gz 47279 BLAKE2B 855f4ebb5619ab4aec429b551fb410855da150916416636737c980712e981a8f3b7339f7691d4fa1ee3439911d6e0733ff2431a520d515b836b183848cfb3013 SHA512 33da70653166525009680cd78e6bb7dabb8518babb73caac26dbea9dbd0b73898d1ffe17755f1505dde1c6a3407c0a31743ea60a66af1b30a587ec39fc4014ff
EBUILD asyncstdlib-3.12.3.ebuild 1013 BLAKE2B 5164d2a8f839393fa594261503601b4d78766e1f66fe83b357a9a5673efaca1fb57bad57417ce496cb51cdbb6e038755087d5535e83e7e320d8fcf37b22e4887 SHA512 15c5f87142a48b87b3d04775d5df0c97d5d666db6cc933f81e0ba534a6e69ccbfa92e8a8040e6105e7c511b992b3f3150ae1ecb625195d1956a7ea9eb5ae8dfb
+EBUILD asyncstdlib-3.12.4.ebuild 565 BLAKE2B fb1cb2cd6406a07ceaf7671e97471eccfb9100e159addaabaa1d31d81796a4ddf9b2b3e66a323e503cf502c2503ddde52b87361539f4b1c23da9c9690d2ffc77 SHA512 2f7f413d391773cd5bab13bdbc68d7b310cc6efb6a9cbffed1ff1a193028a6f48a8ffc9b067a52b6462485b2d0344abe36b10eee644f250471b37e032b728bae
MISC metadata.xml 359 BLAKE2B 10bdbf5adba9cefa912d8e1f195f20d4040bc2e8e3efb3fdc6efcb8272bb58160c6d772de3fe9ad9c4cb43e2817139319ffece082c3c043f1d97cb36ed8ac7a8 SHA512 e56f712f7446a3e68137a945a1ab212f6254740ce2f962fc7ab0061f41cb0d314809ad4fe3317fd10d8ebb594fb20d690d06b0a73636b13b5fdb5184cde2e306
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild
new file mode 100644
index 000000000000..a2eea4011b68
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.12.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}