summaryrefslogtreecommitdiff
path: root/dev-python/async_generator/async_generator-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/async_generator/async_generator-1.10.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/async_generator/async_generator-1.10.ebuild')
-rw-r--r--dev-python/async_generator/async_generator-1.10.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/async_generator/async_generator-1.10.ebuild b/dev-python/async_generator/async_generator-1.10.ebuild
index 51b8ddbb5188..c440c8ba8343 100644
--- a/dev-python/async_generator/async_generator-1.10.ebuild
+++ b/dev-python/async_generator/async_generator-1.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -13,8 +13,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
+KEYWORDS="amd64 arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
DOCS=( README.rst )
-distutils_enable_tests pytest
+python_test() {
+ pushd "${BUILD_DIR}/lib" >/dev/null || die
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+ rm -rf .pytest_cache || die
+ popd >/dev/null || die
+}