summaryrefslogtreecommitdiff
path: root/dev-python/async-lru/async-lru-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-28 10:36:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-28 10:36:33 +0100
commita150275298c698f2489d072115ed2e2591204b31 (patch)
treeae013137d5a37f6c36eb6686defdf7ab36d25baa /dev-python/async-lru/async-lru-2.0.4.ebuild
parent2130804eda00268ce2a34eb936167bcfeb4281a0 (diff)
gentoo auto-resync : 28:07:2023 - 10:36:33
Diffstat (limited to 'dev-python/async-lru/async-lru-2.0.4.ebuild')
-rw-r--r--dev-python/async-lru/async-lru-2.0.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/async-lru/async-lru-2.0.4.ebuild b/dev-python/async-lru/async-lru-2.0.4.ebuild
new file mode 100644
index 000000000000..0e1f63516ebd
--- /dev/null
+++ b/dev-python/async-lru/async-lru-2.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async-lru/
+"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}