summaryrefslogtreecommitdiff
path: root/dev-python/asttokens
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-python/asttokens
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest2
-rw-r--r--dev-python/asttokens/asttokens-2.2.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index d3c1a3fd4801..31be5e077786 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1,5 +1,7 @@
DIST asttokens-2.0.8.gh.tar.gz 50804 BLAKE2B 31b5fcf6c8c201279924da9297f16a1de087fe98e930dde341b54b29a54a23a462d44e1b2cc1c4695e7829b0dbb86c5a275ffac7c8430c191fd268026306c912 SHA512 e920aa50ba7f073f198182c053729e43c7cf3812a925cead258708ba88b82f6a7a32499810e67f346db79579607c07f211d924dc9e33b8bfdf44e5c9f171d53c
DIST asttokens-2.1.0.gh.tar.gz 55584 BLAKE2B eb2a73a47fcbfe1b75e0058f7fcc650ebc3cac00e1f816d2b5b7d02b75aaa07445de854c624e3564455036e2d973bc841e9ad3c18232d88b9091cfc3a2f95c71 SHA512 f89fe2ef700c3c07f48a87e39805792d00abc1050e619a987b863f4befc186505749bde956a95eaf152c4d69e087e32f8fa997cfa5527bbeb87e0143da89a662
+DIST asttokens-2.2.0.gh.tar.gz 55963 BLAKE2B 93bdaf42fc19b0735f4f9c70f20a250d8ac6e99e0d663222133be7c2d306b242c807b0a108e9e6dc6a3b014d19c34c4319de5d4c884113dbeacd0219fc780c87 SHA512 1a803bb99852c0dd186a4afc340c3543e8400efea03dc06331d761f8c70e97711915aaa5ae32aea54bd61fb0d77827c5ab3afaa7762913175a5ad75ca2fff5ca
EBUILD asttokens-2.0.8.ebuild 969 BLAKE2B 6b9b49fd5302742e776a749e00ae0b88bb7298a22f040a84702f63c33ee7569d00a4ee82668cf73ba16f3a4b4346efaefe278d2a20ba4ac6bcf37b7b51d5cd37 SHA512 97d7586f1f2bf7948e1e8d6f66021fbcce79e26d5b42510dd6a9fbc949185b876b55596fbdd18632ec633b2b228ae0708242378a354ba7e269a134cf9deb69e2
EBUILD asttokens-2.1.0.ebuild 972 BLAKE2B a1ff2dbf4563278de21e5c6a58ff36c23517f651dbaf684bd0dd4ee002e6ac1be0f140a38b3cc0d5f9cf1aea9a4deb31fc430c7d8c776503820fa927b5b4457e SHA512 247c5cee11ea243e9447743738d652a0b6f1b6b2788b403b87a4fb64a92797b63e8dcf82f21028a4598dae01c4f0850482136fdf093bc70fd92a97137b5391ba
+EBUILD asttokens-2.2.0.ebuild 977 BLAKE2B 959cd5ea32e19d1ec47961f814a26edffad66f79bac906a64e8eb6ac39eb9992c0ef4923aabe87bb803208b7bf7ee75abc4c3bfb95cb53734ac450e9ea3fa134 SHA512 834be7aa087a7449f3183b1e05b7306b102d4332b81f5cffd57a5823decf4eb27e83b52dea6a4470c37304933c10f06ecf95fc934407b9472f742019113e2e98
MISC metadata.xml 350 BLAKE2B c05dcff93454660cb741def5cb0ca82e56f0cba84bddb9604153b6d70625e4dfc9e15743c3448a0cb68d9b5ccf0778f8126390872bd8689df0e0ab2bed7e6582 SHA512 521762b1e8a542c5f3156014884c3d845b6fe882e819c924aa8023f8dff32a94490e64a1d1f700f5127bd867c60c4f0f7c4aed5c39f78e52bd8ebabd113403cf
diff --git a/dev-python/asttokens/asttokens-2.2.0.ebuild b/dev-python/asttokens/asttokens-2.2.0.ebuild
new file mode 100644
index 000000000000..839fb416705f
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test suite itself broken with new astroid versions, upstream less care
+ # https://github.com/gristlabs/asttokens/issues/79
+ tests/test_astroid.py
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}