summaryrefslogtreecommitdiff
path: root/dev-python/asttokens
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/asttokens
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest3
-rw-r--r--dev-python/asttokens/asttokens-2.0.4.ebuild58
-rw-r--r--dev-python/asttokens/metadata.xml7
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
new file mode 100644
index 000000000000..1cda2195de3f
--- /dev/null
+++ b/dev-python/asttokens/Manifest
@@ -0,0 +1,3 @@
+DIST asttokens-2.0.4.gh.tar.gz 46823 BLAKE2B 111ed58c1b657900f830b7b9f521c1f87fd37945ab6ed6e165108fc2371923030b37cae33885e166a524eb8dd5cfad5fe9391a19b7729b7cd504474d1477748d SHA512 49287259d64c43c7460357d19ed95495ab499b0ad7ae0d5a59378ea0332142b574643349d1d3ca56442712ebec14c53167da475915017feb1b524ac190f9dac3
+EBUILD asttokens-2.0.4.ebuild 1455 BLAKE2B 8d03d2a448c542f054a5eac816addca597d68027085e8d407bfba00f70860943a40bb1971fa6c547b22e2af64b781bafc615e50841e09f6147e7c9697a74ca2f SHA512 2c02dc3aafe0d3dcd9c8323f21fd09124b32a6e7a3dffa537db5d4e562919cde9b80c6cc082055c3a31712a13d81b32455953277a909b081b42ecdc347593547
+MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/asttokens/asttokens-2.0.4.ebuild b/dev-python/asttokens/asttokens-2.0.4.ebuild
new file mode 100644
index 000000000000..cc5ac4e4ecfc
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.0.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ # Kill off useless wheel dep
+ sed -i -e 's/wheel; //' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.9 ]] && deselect+=(
+ # invalid syntax
+ --deselect
+ tests/test_astroid.py::TestAstroid::test_fixture9
+ --deselect
+ tests/test_astroid.py::TestAstroid::test_splat
+ --deselect
+ tests/test_astroid.py::TestAstroid::test_sys_modules
+ --deselect
+ tests/test_mark_tokens.py::TestMarkTokens::test_fixture9
+ --deselect
+ tests/test_mark_tokens.py::TestMarkTokens::test_splat
+ --deselect
+ tests/test_mark_tokens.py::TestMarkTokens::test_sys_modules
+ )
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/asttokens/metadata.xml b/dev-python/asttokens/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/asttokens/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>