summaryrefslogtreecommitdiff
path: root/dev-python/asttokens
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/asttokens
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest2
-rw-r--r--dev-python/asttokens/asttokens-2.0.5.ebuild13
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index edf905537b86..d3a06b6acd63 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1,3 +1,3 @@
DIST asttokens-2.0.5.gh.tar.gz 46876 BLAKE2B 8a8da138888de0a4096b10eccc483c9540710acde0da188ed3fb3845f96b862fe2eec393c69ca62e7b313bfa0e2f0d673d828e9d1ff6dbbf5b641fe8122a548d SHA512 3e710ca9703e67643bb9c0a4db4e5c1656e6d5c904a1262a9ddb962beff06e4e8bd9815bcd2509b48974a97a565d8479a4369583c166a65b6d16c19fd926e93f
-EBUILD asttokens-2.0.5.ebuild 773 BLAKE2B b0ff6b3f024ae2668812a84487ad781b7ce9e722d1c967b7e932fac29a32275230e3c5c3ee05c069e678346b7cadf8d947be48c6161c8891f7d4daab2419f08a SHA512 d26657cbbc02f654654b92913bf4d69bd09df6ac9d3f0e6717296cb3a05808674b86fbb8ba8a59ca374b1f67524fbb89d355b7e838a372ba817087cbca83c7f7
+EBUILD asttokens-2.0.5.ebuild 950 BLAKE2B 823eab9da787046f22eb5acd44a8f3a55981858aea1f4fb8096dff1b5f12e27865b1a8763c081edc0e8575bc0acdf1a365306d1dbb0a7b16a6813d5f1baa3070 SHA512 41f176acba00467ae219891d91df722b80b0588fed4cf53415205ca120bc0aad1b992a2e3b9b83c3d98eb773a1dde8ef66e331a2e41f60f16a19aad99a895f8b
MISC metadata.xml 349 BLAKE2B 98a5cf5c1dd38d72e3a9291bce91e66b23feaae3df2356e68e60bd2fb37a578b3f62d9f1eef8f8966c1cb10dc1c6d0820cfc9977e30c8574f9881177fc58fd00 SHA512 1bb6c8ba010ccdc6a47646021446943063034afeccf89437e6a769f40136e0a8a3875dca5eb40beb119a87e24b37db342542d89acde1fd3a836853f4524f62e1
diff --git a/dev-python/asttokens/asttokens-2.0.5.ebuild b/dev-python/asttokens/asttokens-2.0.5.ebuild
index cf7fc5d2a259..393339cec50b 100644
--- a/dev-python/asttokens/asttokens-2.0.5.ebuild
+++ b/dev-python/asttokens/asttokens-2.0.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Annotate Python AST trees with source text and token information"
@@ -29,3 +29,12 @@ BDEPEND="
distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.8 ]] && deselect+=(
+ tests/test_astroid.py::TestAstroid::test_slices
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}