summaryrefslogtreecommitdiff
path: root/dev-python/asttokens
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/asttokens
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest2
-rw-r--r--dev-python/asttokens/asttokens-2.0.5.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 9933db7d92a5..a90d334e6d51 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1,3 +1,5 @@
DIST asttokens-2.0.4.gh.tar.gz 46823 BLAKE2B 111ed58c1b657900f830b7b9f521c1f87fd37945ab6ed6e165108fc2371923030b37cae33885e166a524eb8dd5cfad5fe9391a19b7729b7cd504474d1477748d SHA512 49287259d64c43c7460357d19ed95495ab499b0ad7ae0d5a59378ea0332142b574643349d1d3ca56442712ebec14c53167da475915017feb1b524ac190f9dac3
+DIST asttokens-2.0.5.gh.tar.gz 46876 BLAKE2B 8a8da138888de0a4096b10eccc483c9540710acde0da188ed3fb3845f96b862fe2eec393c69ca62e7b313bfa0e2f0d673d828e9d1ff6dbbf5b641fe8122a548d SHA512 3e710ca9703e67643bb9c0a4db4e5c1656e6d5c904a1262a9ddb962beff06e4e8bd9815bcd2509b48974a97a565d8479a4369583c166a65b6d16c19fd926e93f
EBUILD asttokens-2.0.4.ebuild 1475 BLAKE2B fb8da0a17a553990a2681f8b048f2a0b38ed194a276e862c2293410bf305dd312f69cd8b38c9c15c6e482cdcd655cdd9f6ad182a2c0650410bea848e4d11c74f SHA512 2e0ac7930a98570c94aa2818793a14eca644c086804187f25269bc6a1b94d0622c4cf82910c01a3a0ef2bff820c1d8fc709663cdb18216d7ab4aa99eceb3ed15
+EBUILD asttokens-2.0.5.ebuild 777 BLAKE2B 434d174d536f0617b454ef53fb66e87867362e5829bafff23414753d0da2b78a814df95d6e48eca905e5cbcf40874ba9ba6d3baf877e89e86e304f2da9d168d1 SHA512 a617317cbba7de1c78cd8e020014a4b8492c9147a7d724c7fdca6e8ba91f0c952426d3872bf7eeb0c5aebb23f44250b959cf745fe1e471260329ffb4a41f2f6b
MISC metadata.xml 349 BLAKE2B 98a5cf5c1dd38d72e3a9291bce91e66b23feaae3df2356e68e60bd2fb37a578b3f62d9f1eef8f8966c1cb10dc1c6d0820cfc9977e30c8574f9881177fc58fd00 SHA512 1bb6c8ba010ccdc6a47646021446943063034afeccf89437e6a769f40136e0a8a3875dca5eb40beb119a87e24b37db342542d89acde1fd3a836853f4524f62e1
diff --git a/dev-python/asttokens/asttokens-2.0.5.ebuild b/dev-python/asttokens/asttokens-2.0.5.ebuild
new file mode 100644
index 000000000000..d1c976711b1e
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}