summaryrefslogtreecommitdiff
path: root/dev-python/astroquery/astroquery-0.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/astroquery/astroquery-0.3.6.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/astroquery/astroquery-0.3.6.ebuild')
-rw-r--r--dev-python/astroquery/astroquery-0.3.6.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/astroquery/astroquery-0.3.6.ebuild b/dev-python/astroquery/astroquery-0.3.6.ebuild
deleted file mode 100644
index 1923b8dd52a1..000000000000
--- a/dev-python/astroquery/astroquery-0.3.6.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 xdg-utils virtualx
-
-DESCRIPTION="Collection of packages to access online astronomical resources"
-HOMEPAGE="https://github.com/astropy/astroquery"
-SRC_URI="https://github.com/astropy/astroquery/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-DOCS=( README.rst )
-
-PYTHON_REQ_USE="test? ( tk )"
-
-RDEPEND="
- dev-python/astropy[${PYTHON_USEDEP}]
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/aplpy[${PYTHON_USEDEP}]
- dev-python/pyregion[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- xdg_environment_reset
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- virtx esetup.py test
-}
-
-python_compile_all() {
- if use doc; then
- python_setup
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}