summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-17 11:52:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-17 11:52:40 +0100
commit58129875a70f3975f864c0c1e322fe85967688b5 (patch)
treed670319b7dc1c4fddc3fb798a202d8c1aba3307a /dev-python/astroid
parent269581204f3555e3dee67f4ecf29dca64a118e48 (diff)
gentoo auto-resync : 17:04:2023 - 11:52:40
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.15.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index dc61e228da63..991e66e5e1c4 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,5 +1,7 @@
DIST astroid-2.15.1.gh.tar.gz 460960 BLAKE2B ec08cc53027323a70291adc888b3621dc139783e6f72859eac05a2c6da0150cc5d19dc6a7278b6a846f985cf44c7d868df1ba11d0c6e3b7a5d3c71a38603743e SHA512 26f85aff9de08d4b413c40951f2aefd2c19304c077b502774b253e3fcced42173bc7e996fac82b3462c6915625ff48fd80dd1ab5e3425aefa103347f821f7df4
DIST astroid-2.15.2.gh.tar.gz 461132 BLAKE2B 1e4d5fa174c7893743ebe9a17b28bdee68fefd35a69802358eb4448402a00622ec56a7ba18a8cdae8cafd9e75bbee9cd18f39bbb44fbcc061c893fc24e308376 SHA512 aea2a55780f81893d8dad4acb572883017e3d6270d48a8f0d3b4520279bc4d79e9d04192479d5aad453ab7bda6d29edf1f56c92d86c04a8ef07bd4561bf908c4
+DIST astroid-2.15.3.gh.tar.gz 461474 BLAKE2B 3631d5d3c591dcf4a7aef0b78a5dea4b7dba90c6c11297fd9a60aefbad7c7a3b8c1dee1adc634991292a6650ad02f4408f8aee15fa0ac67fca4279d86b96f963 SHA512 622a33c6ca278c1036d8f3c7de36d474c8697dd47593ebc6d4987600b779e3901ff7a2ad6d621396bf54ed394a4ea8704dd226d97021b40fd7641756b9b2f975
EBUILD astroid-2.15.1.ebuild 1927 BLAKE2B d05c87932a2c70e6840870b693710fecd3434027d08433c399fcddf8738b23b1dcfb9e3f6fd7cf96b93a4f738db5ff36fd751b7695248400cfaf7f02e0bc4102 SHA512 b7bcb425a787a1d959e555b69cbb35a266dac42fc6fb4e2d8874e4d659a31a1978518c4321db71bd47ddb50094296057d0a702f5b278215ebe051b933d635a25
EBUILD astroid-2.15.2.ebuild 1944 BLAKE2B 02bf83a2d2aa64f1facca32d081cb52e389d504a864d3990a0fad04628e12cd7d119a30058af21950095d1824a11c2ecc3219078da270cbfd65dd8763effb736 SHA512 4f29a0352dc018b061ed2cb665e80be005390ea206989ee23f2b93c794592b8e98e8bdfa2150e256e717f8b6bb44b2d498baf53ff657e53312416ab6362f5fd5
+EBUILD astroid-2.15.3.ebuild 1944 BLAKE2B 02bf83a2d2aa64f1facca32d081cb52e389d504a864d3990a0fad04628e12cd7d119a30058af21950095d1824a11c2ecc3219078da270cbfd65dd8763effb736 SHA512 4f29a0352dc018b061ed2cb665e80be005390ea206989ee23f2b93c794592b8e98e8bdfa2150e256e717f8b6bb44b2d498baf53ff657e53312416ab6362f5fd5
MISC metadata.xml 1148 BLAKE2B 29a6cfc0c292117920be154d37ed4770f1fb1679186576fe6151cc02d1d6be766045e0231e2fceb87cbd250dbed3888c99b7ca7dc0182cc700a11961d9cd6d9e SHA512 6821d13f5e82bd73ee4fd165c0b4c94f40cd6af536dee1658cccb4175e67da2611c4d1478cdef1607535f23224116ad482197e0b0eef8f0a94d596bf250b3074
diff --git a/dev-python/astroid/astroid-2.15.3.ebuild b/dev-python/astroid/astroid-2.15.3.ebuild
new file mode 100644
index 000000000000..39fa50857923
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}