summaryrefslogtreecommitdiff
path: root/dev-python/asn1crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/asn1crypto
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/asn1crypto')
-rw-r--r--dev-python/asn1crypto/Manifest4
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.4.0.ebuild20
-rw-r--r--dev-python/asn1crypto/metadata.xml16
3 files changed, 31 insertions, 9 deletions
diff --git a/dev-python/asn1crypto/Manifest b/dev-python/asn1crypto/Manifest
index fc7530fe42f2..3f11f4c00f51 100644
--- a/dev-python/asn1crypto/Manifest
+++ b/dev-python/asn1crypto/Manifest
@@ -1,3 +1,5 @@
DIST asn1crypto-0.24.0.gh.tar.gz 641322 BLAKE2B eb30afd0d2579f44ee4f556139357dc7622691bdc2067df913a4412cd3dca8372b85d84e3a3cbef6ba83648bf4ef55d7e8614992e2abb019301c92d24b15a926 SHA512 426cc380903b4dd7aadd7b831e3a11ee3442c961a33b856d4aa8d9060e829f2e0ad905a60c4d6504569718fe2cee01d9be31628c89ef030bc34281e381c898e8
+DIST asn1crypto-1.4.0.gh.tar.gz 672812 BLAKE2B 7545d424c244c04c2639df45e0bb56c50de95d0a7ee1e56933720dd7215c2be2608ac7889e2e901785592592e9ac6cb116fff3cd00536903c392a9e3912fc08a SHA512 989e4e0650252c29477d71263549b99f2c51c87f0768c20264b3de65f32edd8e7922e8af23bb1a7e29567a4ad8c4c5d596cdf7db3c766352c7f19d4f93361cd0
EBUILD asn1crypto-0.24.0.ebuild 842 BLAKE2B 235a01eaf99cd9287798da84adc85568f6063c21e8630ca271af6cc7173a56347bccd1ed33751af9e68a069b89bfe5b3d56f23bb87f7cc725ff6249c672509ab SHA512 8d1223fdfead57bccff66c0b6a6f2518999254774ea189e65caed7f4db80ddc2a77fe7322408ae5ad703171c745aedd6e658a5581863f99e335f91c259b05ae8
-MISC metadata.xml 384 BLAKE2B 6dbfdd39bb24b2df61454716e308605ae1d35c3babd01f16556bbbab240e425434315cb2b80a2c3e8e9b18b237899b5fb96566a7ffefde2af3af1dcc2e08362b SHA512 c2806f846608bdd0720b589494e13f57ab2d64026747f2b13f412c9a0e9d2bef6b16fc357e4d16b74ad7a2a2af8daa5e28d0b6bfe4d2141ce68881c724fd24c7
+EBUILD asn1crypto-1.4.0.ebuild 748 BLAKE2B 4c4b27af4da53ae0d83ada5df21829db4b448808fb2218adb8d080df71b3710a3a4748e5ff38c94f06777841914566e66a7346533d398d9bdf03dd8ab5f98cd2 SHA512 cd7e39e83aa036d4f86a2c9fda79d5588be6e84443610656433adb30d8458da3c6719b4b7d6d15fec98f3f9c01560839ad3adb8e54fcfeae5cd3f0f3ddf9142e
+MISC metadata.xml 369 BLAKE2B 10f3c63d43c7c239c32d1d531ae9f72e584e65038c6d8206fc53f91563e1d7bd7e26dce21d7c7c71e1e1b2359f5c46e989497bbcf34bbe373354253a322d74dd SHA512 40fa02100d2e7411d5556931fd91a55b30ad4d42d460bc072ddf0bebeee5cb9559a30d23968be82e49f14f347cdfdfd9b55614e5d48182e2147cf60b23eb1fa3
diff --git a/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild b/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild
new file mode 100644
index 000000000000..9803ec895c27
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest
diff --git a/dev-python/asn1crypto/metadata.xml b/dev-python/asn1crypto/metadata.xml
index 2dfa57bc0fb6..94d6d17f750b 100644
--- a/dev-python/asn1crypto/metadata.xml
+++ b/dev-python/asn1crypto/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">cryptography</remote-id>
- <remote-id type="github">pyca/cryptography</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">asn1crypto</remote-id>
+ <remote-id type="github">wbond/asn1crypto</remote-id>
+ </upstream>
</pkgmetadata>