summaryrefslogtreecommitdiff
path: root/dev-python/asn1crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/asn1crypto
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/asn1crypto')
-rw-r--r--dev-python/asn1crypto/Manifest4
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.5.0.ebuild20
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.5.1.ebuild21
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/Manifest b/dev-python/asn1crypto/Manifest
index 4b58541072ca..5ebce5f041e6 100644
--- a/dev-python/asn1crypto/Manifest
+++ b/dev-python/asn1crypto/Manifest
@@ -1,3 +1,7 @@
DIST asn1crypto-1.4.0.gh.tar.gz 672812 BLAKE2B 7545d424c244c04c2639df45e0bb56c50de95d0a7ee1e56933720dd7215c2be2608ac7889e2e901785592592e9ac6cb116fff3cd00536903c392a9e3912fc08a SHA512 989e4e0650252c29477d71263549b99f2c51c87f0768c20264b3de65f32edd8e7922e8af23bb1a7e29567a4ad8c4c5d596cdf7db3c766352c7f19d4f93361cd0
+DIST asn1crypto-1.5.0.gh.tar.gz 686107 BLAKE2B 9a21c50b5b2c0504178efa0cd5389d004595020ee87b7a5c8e469f9c2de8eb75817d507cd2f8fd0515087d63ca8b135f4c3b85db418997ccbff286e2551c0a1c SHA512 2045ae0ddf777c7a6bc6ba946f457e6a2561d4ebe8fa0ad5b6663af345c6a232a4fd1751dcad6e3c4a99b56c06148801485fb81f1a48e04b1b711dda9d6d0e54
+DIST asn1crypto-1.5.1.gh.tar.gz 686175 BLAKE2B 1e308ac17c36daaa9ca69fc48ccf0465e540b07d96c1a3e6977844994950e2c75061d7b88525b7e46b61e5c725ac4505ada8757d51ac67c72f11f86917fca54b SHA512 1bcb93d82a2602e3b5c66a180f5d16cd3a9731d86d89fbd44c1e23d735e708e9bf9bb6cbabc2a5d60619f51a7c38dfb1f7ed63820f422ccf42800a39f4637626
EBUILD asn1crypto-1.4.0.ebuild 742 BLAKE2B 2f9d95b41671e22a1c2e8e04fdd84782475b79d11426ae001e00f8b92fe2c13bcb6fb6da41ca24be813d04ebd418688c510c6d8f6419792712108e7038c727d0 SHA512 6896d25a8dea69604de1b5703cde9df74c89df06256c2fc95161f7d9f43954200cc063d12ae542762ef1b0cc848022fd8e829134a60d800e93ad6e9e8b6e6339
+EBUILD asn1crypto-1.5.0.ebuild 749 BLAKE2B 0fb46e54190699ebe4fb248ea0b39ec3b2413676d43e1cd06dba50759f9a0c3c0e6f79c54c64792b7684dd35d8b9c59e0b841a8eea4c22d359c9bac5544cb612 SHA512 18bffa1f0b57d0d876a66fffd71f0c1b0f20ff10f37b2343f48e35016ec0307119816d0ef46fc1fd6b06057ab5fb285dd8f8a80871fb352caae4b9ee70f7a5e0
+EBUILD asn1crypto-1.5.1.ebuild 781 BLAKE2B 99acc633e2b8e7bcb54846614a5917adeb5027dd0383eac14da12504d4e80799e224af868dc9eed706fb06bc860865e4ccd5e3028784771ddcc1e7d5f6fe6f18 SHA512 3e532cc53325cd3b6373a813c891a9ea95fe14e7b6e8c25ae3da7c3ae90477076eb7b5cd70f201f5e4521a732eabdf860f1e296286cd02ff50a85ffd77d5ef68
MISC metadata.xml 394 BLAKE2B cb3902bf00ff0b7ad12e9e9354c399c86822f90d2bc92b52adfd45e04f3bdde21f803783ad8b69c518fd1b01e9e3d3d0a1a3c7753303cabb0905ec049e92f3ec SHA512 88d151e398b1ad0e0f2416a561bd0ec21c5fc65b9b62ebd2ede159123254d8bff2bdc49b0ca22da628a126602d9d2c94600855e403531cfb4124587c7913e93f
diff --git a/dev-python/asn1crypto/asn1crypto-1.5.0.ebuild b/dev-python/asn1crypto/asn1crypto-1.5.0.ebuild
new file mode 100644
index 000000000000..6d42655df619
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest
diff --git a/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild b/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
new file mode 100644
index 000000000000..081b08e25a79
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest