summaryrefslogtreecommitdiff
path: root/dev-python/asdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/asdf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/asdf')
-rw-r--r--dev-python/asdf/Manifest4
-rw-r--r--dev-python/asdf/asdf-1.2.1.ebuild54
-rw-r--r--dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch53
-rw-r--r--dev-python/asdf/metadata.xml21
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-python/asdf/Manifest b/dev-python/asdf/Manifest
new file mode 100644
index 000000000000..7d2a8df5c135
--- /dev/null
+++ b/dev-python/asdf/Manifest
@@ -0,0 +1,4 @@
+AUX asdf-1.2.1-Disable-test-that-require-http-server.patch 2043 BLAKE2B e0f25fc217eafcdf451bc5a6417ca2b4521db0a17b7144e6654c22d949a3915b8b4194bc1c0ab1a92add64e3b1e20384a521afee58b3ef946339670133dc5981 SHA512 0bd18603e37027d4daf9227fb7c34b48dfca47bd01771dac6be894938c625b0753769764e7ac7b9b23463c6f1d52f7732b960764ccf3ca8d3904e0d5de88e2e7
+DIST asdf-1.2.1.tar.gz 320828 BLAKE2B 8050b24616ba56ac8d946a579da1a8962e54f22db45c8c95c45cccf4552355f68e6983c3831b60aa18d7c33a3914b1984ac31ce3461568bd5c4dee6625c113be SHA512 ac8b94ee1c0e2f1d99d55e38d13cd78e7fb14fbf8b5e15a725c61560e14ab96401a53909954ac6cde825121c6a1205b2d3b8ca474499b90461a2f0ebb5db4638
+EBUILD asdf-1.2.1.ebuild 1328 BLAKE2B ec1a9af7f5892b790c16c972a3a2d4637c3ed8318547a303b3781af0f3cbf11775135aec84c11707d4295c7b8d0672b6d09a18fc8e493895fc542edef6faabc9 SHA512 4529733ef96c6d6099b6b48bdbfd5c555f0de51042a2cb8a5c956f02401524a9727f40568be012e8acec3864c25838b4fabe1c3411fcd037961421b154d9a3fc
+MISC metadata.xml 912 BLAKE2B 71dff7af9bd8506d3819e00a21b45659088ef3876f0f8a481809ed7f4f8c53e04044ff6ac6adabbaa60be00489cd4482c3c7c853bd240789175c2310885a8b82 SHA512 3594bcaf9bb04369baeeea29f728653efbbe2e77b2b77127a34d6b0bc03e5cfb7405f21341df351e86accd774838808aafd73c533c8995d875882436cc898c66
diff --git a/dev-python/asdf/asdf-1.2.1.ebuild b/dev-python/asdf/asdf-1.2.1.ebuild
new file mode 100644
index 000000000000..5e8539f7a8ae
--- /dev/null
+++ b/dev-python/asdf/asdf-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for the Advanced Scientific Data Format"
+HOMEPAGE="http://asdf.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Disable-test-that-require-http-server.patch
+)
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch b/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch
new file mode 100644
index 000000000000..e59d48246000
--- /dev/null
+++ b/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch
@@ -0,0 +1,53 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Sat, 5 Nov 2016 14:03:24 +0100
+Subject: Disable test that require http server
+
+Network connections are not available in pbuilder.
+---
+ asdf/tests/test_generic_io.py | 12 ++++--------
+ 1 file changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/asdf/tests/test_generic_io.py b/asdf/tests/test_generic_io.py
+index 3f48eab..b90ca7e 100644
+--- a/asdf/tests/test_generic_io.py
++++ b/asdf/tests/test_generic_io.py
+@@ -241,8 +241,7 @@ def test_streams2():
+ assert len(x) == 60
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_urlopen(tree, httpserver):
+ path = os.path.join(httpserver.tmpdir, 'test.asdf')
+
+@@ -260,8 +259,7 @@ def test_urlopen(tree, httpserver):
+ assert isinstance(next(ff.blocks.internal_blocks)._data, np.ndarray)
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_http_connection(tree, httpserver):
+ path = os.path.join(httpserver.tmpdir, 'test.asdf')
+
+@@ -284,8 +282,7 @@ def test_http_connection(tree, httpserver):
+ ff.tree['science_data'][0] == 42
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_http_connection_range(tree, rhttpserver):
+ path = os.path.join(rhttpserver.tmpdir, 'test.asdf')
+ connection = [None]
+@@ -348,8 +345,7 @@ def test_exploded_filesystem_fail(tree, tmpdir):
+ helpers.assert_tree_match(tree, ff.tree)
+
+
+-@pytest.mark.skipif(sys.platform.startswith('win'),
+- reason="Windows firewall prevents test")
++@pytest.mark.skipif(True, reason="pbuilder prevents test")
+ def test_exploded_http(tree, httpserver):
+ path = os.path.join(httpserver.tmpdir, 'test.asdf')
+
diff --git a/dev-python/asdf/metadata.xml b/dev-python/asdf/metadata.xml
new file mode 100644
index 000000000000..d9905abb5f0e
--- /dev/null
+++ b/dev-python/asdf/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ ASDF (Advanced Scientific Data Format) is a proposed
+ next generation interchange format for scientific data. ASDF aims to
+ exist in the same middle ground that made FITS so successful, by
+ being a hybrid text and binary format: containing human editable
+ metadata for interchange, and raw binary data that is fast to load
+ and use. Unlike FITS, the metadata is highly structured and is
+ designed up-front for extensibility.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">asdf</remote-id>
+ <remote-id type="github">spacetelescope/asdf</remote-id>
+ </upstream>
+</pkgmetadata>