summaryrefslogtreecommitdiff
path: root/dev-python/argh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/argh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest4
-rw-r--r--dev-python/argh/argh-0.26.2-r1.ebuild30
-rw-r--r--dev-python/argh/argh-0.26.2.ebuild30
-rw-r--r--dev-python/argh/metadata.xml11
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
new file mode 100644
index 000000000000..599df7504e2b
--- /dev/null
+++ b/dev-python/argh/Manifest
@@ -0,0 +1,4 @@
+DIST argh-0.26.2.tar.gz 32913 BLAKE2B 315dc36c4a98cb4a8fdab68a30ed3d4d87d1565717722ed496255d8b1b4e505277032217da4c5d750f210974890d8094c52f920044173ff2168adf7cb7f6a2bd SHA512 90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707
+EBUILD argh-0.26.2-r1.ebuild 687 BLAKE2B 29eeb6a222316146f3395b182ce237d9918650dcdbb0e176d4ef033f7660281ae9469376f150a208766232703312cb064f919bf94748b05b569a5c766256202f SHA512 885c0fdd7d1e93f25c155bef03ceaf451300660427f3f310152945afb77442b3df8c38bdf4991b0b95b6f26e8aeab6e5625e1135e195ef54d062287ee1ac6b39
+EBUILD argh-0.26.2.ebuild 683 BLAKE2B 43746e1b54becfd3abc7122ecab1177976dc702cc05699a0cad7951729722f791724127a9d43deaab6ac5f0dc7ff80aaef4d98cef9e82e1b79d38c3ece2ad5ea SHA512 fa139347f6d7f712f7f7460e7869f28b20ad8d2cd9ff1824cc05420a9ffd9a28044f81d3f302b15e8df3b7e33111859f2b4b429579db68ee396cb5a7b6c87ca5
+MISC metadata.xml 307 BLAKE2B 172ad4318c81373d000c3138ea3efd86183f1b17fbbdbb793a99aa43732c85ebbaa90235096835ca07a70db115fad09debf1f9ca3c5a46f6f01b6273b4e04d5a SHA512 6236f4f54de93e831341d268725741e3a46e4a4cd815ead1d5751ab551ec06fd58acb410d2cff973c992d564b69f21e6e56168ad567fe3e7c810eca5c2a83712
diff --git a/dev-python/argh/argh-0.26.2-r1.ebuild b/dev-python/argh/argh-0.26.2-r1.ebuild
new file mode 100644
index 000000000000..39bd79afca52
--- /dev/null
+++ b/dev-python/argh/argh-0.26.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="https://pythonhosted.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/argh/argh-0.26.2.ebuild b/dev-python/argh/argh-0.26.2.ebuild
new file mode 100644
index 000000000000..1ac96d8bd62f
--- /dev/null
+++ b/dev-python/argh/argh-0.26.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="https://pythonhosted.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/argh/metadata.xml b/dev-python/argh/metadata.xml
new file mode 100644
index 000000000000..0e0938894bcc
--- /dev/null
+++ b/dev-python/argh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">argh</remote-id>
+ </upstream>
+</pkgmetadata>