summaryrefslogtreecommitdiff
path: root/dev-python/argh/argh-0.30.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
commit68883bef20f77c2d72dfdf20bf5f9d4a5ea5ad9c (patch)
tree5bea0b1c5edcc839425e169609eb2bb2fc6aa760 /dev-python/argh/argh-0.30.4.ebuild
parentd0f8b473674427ef4f618c94d4d132a7f79578e3 (diff)
gentoo auto-resync : 05:11:2023 - 10:11:29
Diffstat (limited to 'dev-python/argh/argh-0.30.4.ebuild')
-rw-r--r--dev-python/argh/argh-0.30.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/argh/argh-0.30.4.ebuild b/dev-python/argh/argh-0.30.4.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.30.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest