summaryrefslogtreecommitdiff
path: root/dev-python/argh/argh-0.28.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 20:05:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 20:05:28 +0000
commit41e056b08e4c5c8d6e78407a5586afa52867fd5f (patch)
tree5c065bb2a5c9eb0386762c79e910ad74512def88 /dev-python/argh/argh-0.28.1.ebuild
parentb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (diff)
gentoo auto-resync : 16:02:2023 - 20:05:28
Diffstat (limited to 'dev-python/argh/argh-0.28.1.ebuild')
-rw-r--r--dev-python/argh/argh-0.28.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/argh/argh-0.28.1.ebuild b/dev-python/argh/argh-0.28.1.ebuild
new file mode 100644
index 000000000000..a5678353c3de
--- /dev/null
+++ b/dev-python/argh/argh-0.28.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest