summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/argcomplete
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest2
-rw-r--r--dev-python/argcomplete/argcomplete-3.5.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index e2641737dcb8..f37ad2573f56 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,4 +1,6 @@
AUX argcomplete-3.1.6-timeout.patch 945 BLAKE2B dcdfadbdef547d45013eee33d00166b98eb6621a55f5e399cc7d330541a95118aff4a1646a85a1351209f88ff0e74d66e2468ffcf3db7e91d44ef453cc9c73e9 SHA512 fc26fc219d88a74d49245a2d545cb8040fb773fc7a948847380d4d343f19650994771a948fce99311cab7b52b3e040cf3f58291a0ac50b4a4f262dbb28c1bf85
DIST argcomplete-3.4.0.tar.gz 82275 BLAKE2B 18b81aa5ee0c148a3b935f157f4c39b0ade79b36c8e3aa94aa7af8a424a08793a4cf661cb2431c201d5eead02e12c35b78d351310ff4e4e750bf7d7dc702ca89 SHA512 bd619a34edf1f1d05bdfab7fa830d1fc5375bc292dc95b95ddc4d3bfaced5728067e6ad0a901f672b7e0d5a550c10b00e0851f83cf9b358301c037da256a4a56
+DIST argcomplete-3.5.0.tar.gz 82237 BLAKE2B 7a5acd6f1311ec153333363e207037634b6901cca1415bd68d8e009888fa8cdfdfc3a50189f14c5da4bddfa5c861bbc009cf0d34248ff168caaa6ebad6ad8a7d SHA512 89c305a97b0808301976a48f9c8cb914e7cc12e33540cebd1c6514bbed8017db27b2232e3526abb74fe4f152f23c211be5a48aeafd63bbfca2dcc42f92b4877e
EBUILD argcomplete-3.4.0.ebuild 1046 BLAKE2B d6d3ff2b182c7c85650b7eb0f70e98bdb0e214887bd0e236dcc36989cc6225f17c502c1e97a4a80be621d95e008966872e7f508e3476da263bc8959dd26a319c SHA512 5f780c79d97de376fd2d0eb115b49da2b31c0358a0784074de791e04901aac5550da5fca89b7f8c247fa68dca8dfc741f1f10f5cc1e398c0f81bfaff463edac4
+EBUILD argcomplete-3.5.0.ebuild 1054 BLAKE2B ddc6a1d63df7e5b658daa0297544c7b6de30a58b9e2d541ffb8d335c26a8786567356aef5fee6aec5e37fc2a30b92a87ed81c32e1c25d86b3fcc91a7b4b9be77 SHA512 79c1a03efbdd3dfc9390af69b90a0c4f17d0b47ae8f350002e71bfc4b9eb259e86a3f87dbe7dd26065c6f5a8e8d2cc5397f5bc58a8596b819c71edb81f4802e4
MISC metadata.xml 411 BLAKE2B 963cfdba9183fde9e97c534345164d26be569d841dcc6fd274601b18d5de2ae97fa837b0acfdc59616c5d19cc54ea368547ffd901f90239cdfb5ba08e8721607 SHA512 22db237979be34053ad7201f599d576a7756b71e6b75c40c2808d47f276cce6d3594ae46dcaec5aa5adab9e9e24e11d47bb9044a8b1a146163d66687965cf5b7
diff --git a/dev-python/argcomplete/argcomplete-3.5.0.ebuild b/dev-python/argcomplete/argcomplete-3.5.0.ebuild
new file mode 100644
index 000000000000..645def2f41b7
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}